Untethered 5.0.1 (iOS 5.1.1 - 9B206f) support added to Seas0nPass

So is this the most recent version of OS5.1?  I.e., do I have to upgrade my ATV (currently 5.1 4099 or whatever that version was for the tethered JB) before running Seasonpass?