untethered 5.0.1 & aTV Flash 1.5.1 = XBMC failure?

  • download latest Seas0npass (

  • jailbreak ATV2 with 5.0.1

  • download latest aTV Flash Black (1.5.1)

  • install aTV Flash Black on ATV2

  • install XBMC through Maintenance


When I try to run XBMC from the main menu it goes to the submenu where you once again select XBMC, which is normal, however it immediately takes me back to the main menu … XBMC will not load!

I have tried reinstalling XBMC numerous times with aTV Flash Black, NitoTV and manually through SSH but nothing works. Has anyone had this same trouble? Could anyone suggest what could be the problem and/or how to fix it?


Could be that XBMC 11 was released earlier than ios 5.0.1


This works great for me today with 5.0.1


jailbreak with seasonpass.app

ssh root@appletv.local

apt-get update

mkdir -p /Applications/AppleTV.app/Appliances

apt-get install org.xbmc.xbmc-atv2

mkdir -p /Applications/XBMC.frappliance

wget http://dl.dropbox.com/u/14341410/org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

dpkg -i org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

rm org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

I have tried again using this same technique you suggested a couple of times now, but when running the first command “apt-get update” if goes fast until about 77% then really slow and eventually fails somewhere between 77% and 99% with error messages like “unexpected end of file” … it seems that is might be having trouble connecting to cydia.zodttd.com properly, or more likely the server is overloaded.

servers seems overloaded as everyone is updating now… give it some time… 

Done jailbreak last night on ATV2 it has worked but only tethered and I cant get XBMC, Media Centre or Last FM to work. None of them will install. Can anyone help. As far as I am aware the season pass I downloaded and aTV flash black are the latest versions. Can anyone help

The note above is correct, cydia.zodttd is really, really overloaded so serving files at bytes/second before choking and dying. Persistence will get through or wait until the demand dies down. Took me several hours to get a clean copy.


I tried at 2:30 AM (EST) for about 2 hours and always fails. Also Media Player fails. Is Media Player downloading from Cydia? Maybe there is more to it. 

It doesn’t matter what time of day or night you try because it’s always peak time somewhere in the world. I just kept trying every half hour and eventually got it working on the 7th attempt.

Everything installed fine and works ok but for some reason the entire ATV2 seems slower and laggy now, not sure if it’s just the new firmware version or something else so I will try my another ATV2 soon and see if that is the same.

Done 2 jailbreaks, both work with xbmc only I’ve got problems with installing NitoTV. Any help?


What’s NitoTV?




im still having the same problem on 3 ATV2’s


wget http://dl.dropbox.com/u/14341410/org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb

this link is down for me.


Resolving dl.dropbox.com…,,, …

Connecting to dl.dropbox.com||:80… connected.

HTTP request sent, awaiting response… 404 NOT FOUND

2012-05-27 23:02:46 ERROR 404: NOT FOUND.

try swapping that command for this one instead:

wget http://mirrors.xbmc.org/apt/atv2/deb/org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb


Thanks man i was searching for a mirror just as you posted this! 


R U Happy?


Just now, yes. But I’m still wondering what NitoTV is?

Google is your friend: http://wiki.awkwardtv.org/wiki/NitoTV


Thanks, I want to install XMBC and NitoTV. Is there a specific order in which they should be installed. Having never done this before I’m really not sure.

NitoTV can install XBMC.