Unnable to change to AppleTV Mode. Unmount failed

As I´ve seen in this forum it seems to be a problem since the new update (4.1). Also, there is no going back!!!
I´ve tried EVERYTHING from every possible forum. (HACKINGT0SH, ATVHACKS, Awkward TV…) and NOOOOTTHIIINGGGG!!!
Somebody suggested that the problem was the USB flash drive. Why? It worked great before, for every patch or hack!
Is there a solution in the future? I´m really pissed that I´d had finally the best possible config. in my ATV, now NOTHING!!!

Best regards to all

I received this same message today as well - about 20 times. I reformatted two USB sticks, including reformatting to zero out data, over and over again, multiple times. I’ve spent all afternoon working on this an will now give up. I’ll be requesting a refund for this program as it obviously doesn’t work given the problems that are showing up on this support site. First it was the partition problem, now its the unmount failed message. What’s going wrong?

i keep getting the same error. not working at all. i hate ATV Flash, i just ordered popcornhour. ive always had problems like this. they dont even reply to posts to help us out.

If you’re having trouble installing please send an email here: http://www.atvflash.com/contact.php

same here, this is so annoying. nothing is working.

try posting a solution rather than asking us to email you which that doesnt work because you guys reply with the same useless steps on the website…

please post a working solution.

Reinstalling ATV has never been easy for me - I have had to do it several times, and each time I’m met with the same headaches. I follow the same steps over and over again, and I follow the same advice given in these forums, but with the same results. The rare times in the past when I have had a successful reinstall it’s been b/c of chance…I did the same steps that I had been doing (maybe 20, 30 times) and then it finally works. It’s not how a product is supposed to work, but based on my experience if you keep at it, eventually it will install correctly. I’m in the process once again…trying to get it to install on number of different zeroed-out USB drives but with various errors being thrown at me.

Do you happen to have the ‘Clean My Mac’ software installed?

I get the same error!!!

Tried with 4 flash drives, NO WAY TO GET IT WORKING!!!!!!

 

What type of drive(s) are you using?

I had the same problem, but funny enough I had another usb drive and it worked no problem...