unknown ios detected ATV2 on iOS 4.3 (4.2)

I just bought an apple tv 2 from a well known online auction site.  I was assured by the seller it was on iOS 4.2.

When I try to download the blobs using ifaith I get the error “Unknown ios detected on this device! aborting…” at the point on the progress menu on the left “Detect iOS” so cant get any further in the jailbreak process.

I ran tinyumbrella which states “Installed Firmware Version 4.3 (4.2)” so its not updated yet to ios5 which seems to be the usual reason to get this message.

any thoughts why ifaith isnt working ??

Im an apple tv newbie so maybe its not jailbreakable anyway but thought if it was not iOS 5 it would be ok ?



Try to run Seasonpass , right click on ‘‘create IPSW’’ and choose your firmware. Maybe it was jailbroken and restored back , if it is not new. SHSH blobs could be saved by previous owner.

if I buy atv black and it doesnt work, can I dowload a new version once (if?) they figure out a way to get it working on ios5 without paying again ?

is this error to be expected in my situation or is something else wrong here ?



ATVFlash updates are free for 1year.

but Im still confused why I get this message in ifaith - shouldnt it be able to save my blobs whilst Im still on 4.3 (4.2) ??

Please download latest seasonpass and test as I explained before. 

Having the exact same problem on 2 ATV2.

They both are running 4.4.4 (3330).

Tried on 2 different Windows PCs with different cables but having same problem.

Also, tried the latest seasonpass but it says no blobs or something like that.


Would appreciate some help. Thanks.

I have been successful on 2 or 3 different occations by doing a RESET through the Apple TV menu, this just clears all the settings and it worked.


DO NOT hit restore!!

I have same problem.  ATV2 has unknown ios detected on iso 4.2 (2060) when using iFaith to save Blobs.  Anything we can do? I want to jb my ATV untethered.  Please help.

Try tinyumbrella

I tried TU but it seems not recognize my ATV.  Can you please guide me how to do it exactly? Thank you.

Can I jb 4.2 (2060) without saving Blobs? How to?

Plug power and USB in


Thank you so much Flipmode.  I successful got blobs save but with 4.3 (8F455), original one is 4.2 (2060).  I built the ispw and finally did restore by using itunes.  Sadly, I got error 1600 and 1601 everytime I tried (at least 10 times).  I used 3 computers.  I changed 3 different hdmi cables. Disable all virus protections.  But not get restore done.  Any ideas?  Thank you and lot of appreciate your help.