Uninstalled XBMC, now I can't install Plex or Couch Surfer

I installed XBMC and didn’t care for it, so tried to uninstall it.  I had to use Cyberduck to get it fully off the AT2.  Now It seems I can’t install any of the other plug-ins, I just tried to install couch surfer and it acts like it is installing, but it does not show up on the menu screen.  





I followed James instruction to remove via cyberduck but maintenance stills shows it as installed. When I try to remove, it goes through the motions, but stays. I did a hard reboot, unplugged ATV2 and replugged. Did nothing. Thinking a reinstall of ATVblack may be the only solution. Also, cannot install Nito to try for a XBMC install. It says it installed it, but does not. 

same problem over here

I did the reinstall of ATV black.  Nito was there of. Maintenance still showedXBMC as installed when it was not. Reinstalled XBMC from Nito just to see what would happen. THen tried to do the Hulu thing. No where with any of it. Manually deleted XBMC. Stills shows as installed and now I can’t uninstall Nito.

This is the message I get trying to install XBMC via ssh as per XBMC instructions using their Cydia version.

E: Could not get lock /var/lib/dpkg/lock - open (35: Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it? Apple-TV:~ root# apt-get install org.xbmc.xbmc-atv2

Got it all fixed. Bottom line. Did apt-get auto remove with SSH to clean out XBMC. Finally showed as uninstalled. Then I was able to Uninstall Nito ( wonder if open ssh was interfering?) Did a clean install of XBMC via ssh with Cydia version from XBMC forum. Working. Even have the Hulu add on working, which is what this entire process was about. So, some file was hanging somewhere even after James’ manual delete was done until I did the apt-get autoremove thing. :) Learned more about terminal and Cyberduck use than ever. Good experience. Thanks all. One day I may even be tempted to undo it all and reload XBMC from Maintenance or Nito as a check.