Unexplainable metadata scraping errors

In general I get 100% accuracy with Infuse’s movie identification, when I use the exact name and year found in tmdb and tvdb. But this one stumps me. I have the movie “The Secret Scripture (2016)”. When named exactly as per tmdb, Infuse instead identifies it as “Kingsman - the Secret Service (2015)”.

I can go in manually and edit the metadata, and the correct movie shows up in the list of choices, but this is silly. Infuse doesn’t even need to guess the right movie in this instance. I’ve given it an exact match and Infuse refuses to use it.

Why isn’t Infuse picking the name-identical choice here? On my Android TV with Archos Media Player it identifies correctly without a hitch.

Yes, that does seem strange.

It could be just an odd result returned by TMDb, but we’ll take a look and see what we can do.

On the bright side, once you make a correction in Infuse it will sync to iCloud so you see the correct info on all your other devices. :slight_smile:

I am also having metadata issues. IN previous versions, Infuse was able to ID some of my movies correctly, and those it could not, could be searched out via the edit option. However, I have just found an anomaly, that being a film with Liam Neeson called After.Life (yes theres a stop in the middle). I used to be able to correct this, but now I cannot. All versions of After Life, with or without stops, are not the correct version. Is there some way to address this issue? Clearly its to do with a current database which no longer has the info, but what to do?

If there’s a common element, it seems to be where the TMDB data contains a punctuation mark in the middle of the title. Naming the local file differently doesn’t seem to work; it’s the punctuation marks in the TMDB end that Infuse isn’t parsing correctly.

So in the above example, it can’t work with ‘After.Life’. In my case, it applies “Kingsman: The Secret Service” to “The Secret Scripture”.

I wonder if Infuse is somehow ignoring everything before the punctuation mark and only guessing based on a couple of words that follow it?

And yours is ANOTHER strange one but fixable. If you name the file “AfterLife.2009.mkv” it will snag the correct metadata and pics. Note there is no “space” or “period” between “After” and “Life”.

Don’t ask me why, it’s all voodoo as far as I can tell but this works.

When naming a file in Infuse period, space, underscore and dash can all be used interchangeably as separator characters. That means that if you have a file name that has a space followed by a period followed by another space the metadata search will interpret this as three spaces.

You can see some of the naming convictions for Infuse here Metadata 101 – Firecore

You can also see James’ additional instructions here Infuse Pro 5.6.7 not connecting to all NFS shares - #6 by james That post also has a link to other illegal characters for file names.

I’m still trying to figure out your particular issue with “The Secret Scripture (2016)”. There almost has to be a “secret decoder ring” to find the file name that will pull up the correct metadata I just haven’t found it yet. :wink:

Hi all,

Yes there is a problem with this English title and “Kingsman : Services secrets”, probably a very rare problem between 2 movie titles.


I have solved the problem by renaming it with the french title “Le Testament caché (2016)”, with the title in French the film is recognized and it is displayed with the English title in the infuse menu, until we find the English title which will be recognized by infuse :slight_smile:


See you

I assure you that I’m familiar with the naming convention. But in this case, none of those special character issues appear in what I am naming the file. I can call it “The Secret Scripture (2016)” or “Secret Scripture, The (2016)” or even just “The Secret Scripture” and it pulls up metadata for “Kingsman: The Secret Service (2015)”.

It’s especially weird because I often get more accurate metadata by specifying the year in my file name. Doing that sorts out potential ambiguities before they happen. It didn’t work here though.

And naming my movies in French shouldn’t be the answer! Just to confirm - The Secret Scripture is an English language film, it has NO other primary name or alias, no Americanised spelling, and a web search on TMDB pulls it right up. Like I noted in my original post, I use Archos Video Player on my Android TV and it parses the exact same file on the exact same NAS drive perfectly.

All I can conclude is that Infuse, when indexing off TMDB, is treating colons or other punctuation marks incorrectly so that Kingsman: The Secret Service actually appears a closer match than a movie with exactly the same name as the correct item.

As I said in my post, I’m still digging into “The Secret Scripture (2016)” issue. I too have tried just about every combo I can think of with the same results. There’s another oddity with this movie, while it’s original release date was in 2016, according to themoviedb it was released in the U.S. in 2017 so I thought I had found the issue but no matter what year I tried it still came up with the dang Kingsman movie.

You keep referencing using a colon in the file names and that is one of the ones that is not allowed. While the actual movie or tv series may include the illegal characters the file name on your server can not. It will cause issues. Also having multiple spaces whether it’s all spaces or a combination of characters that are interpreted as spaces will also cause problems with some names.

I’m going to keep on hammering on “The Secret Scripture (2016)” to see if I can get it resolved. Thanks again for the input.

I’m afraid the latest version (as of 29 April) is still throwing up silly errors.

Try “The Gift (2015)”. There’s a movie with exactly that name and year in TMDB. That’s how I’ve named the mp4 file, precisely.

Yet Infuse, for reasons best known to its programmers, ignores BOTH the name and year and tells me that the movie is “The Good Witch’s Gift (2010)”! If you click to edit the metadata, the proper movie comes up as the first alternative, but why is Infuse getting this wrong? Both the name and year. 2 mistakes out of 2 possible. Sheesh.

Unfortunately, it appears TMDb is delivering strange results for this search. For example, here are the results when searching on their site for ‘The Gift y:2015’.

https://www.themoviedb.org/search?query=the%20gift%20y%3A2015&language=en-US

Fortunately, in Infuse 6 you’ll only need to manually correct things like this once. The changes will sync to iCloud and be available for all your devices moving forward.

Here’s another one.

I have both RoboCop (1987) and RoboCop (2014). Infuse insists on linking the precise named file “RoboCop (2014).mp4” to RoboCop (1987). I’m giving it the exact name and year as per TMDB, and it picks the wrong metadata.

Easiest possibility, try the edit metadata for the one that is incorrect. Once you have selected the correct version in the edit Infuse will remember it. As to a file name change I’d suggest using “Robocop 1987.mkv” and “Robocop 2014.mkv”. When you have the “()” around the year in addition to the spaces it seems that Infuse sees it as having a double space and for some reason will occasionally ignore the year. I’ve seen this on other movies that have multiple versions in different years.

I’d try the edit metadata first though.

Unfortunately, this is another TMDb quirk - as searching with the 2014 year on their site shows the 1987 version as the top result.

https://www.themoviedb.org/search?query=robocop%20y%3A2014&language=en-US

NC’s suggestion about making a manual correction is probably the way to go.