Unable to update xbmc or install NiTo tv (4.4.4 untethered)

So, simply put, I can’t seem to update xbmc or install NiTo tv. I’ve tried seemingly every trick in the book, but this is what I get in my attempts to upgrade xbmc:

The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
Need to get 49.0MB of archives.
After this operation, 0B of additional disk space will be used.
Get:1 http://dl.firecore.com org.xbmc.xbmc-atv2 11.0-3 [49.0MB]
Err http://dl.firecore.com org.xbmc.xbmc-atv2 11.0-3
Undetermined Error
Failed to fetch http://dl.firecore.com/black/deb/org.xbmc.xbmc-atv2_11.0-3_iphoneos-arm.deb Undetermined Error
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I’ve tried to fix missing and still get the failed to fetch. I can’t figure out how to do the install from another mirror.



I browsed the following directory:


Emptied out all the files there and that’s all it took. Life is now good on my XBMC front. Who knew. Freaking files.