Unable to SSH after jailbreak

Could really use some help with this.

Using seas0npass for windows, I was able to successfully jailbreak my ATV2. However, after a couple of weeks use of XBMC with it my SMB would no longer work, would get operation timeout, could not connect to network error within XBMC. Tried to SSH into the device but Putty just gave 'Network error: Connection timed out' error. I could not ping the device either.

Restored ATV2 to non-jailbreak version. Retried seas0npass & it told me jailbreak was successful. But now I cannot SSH into it. Still get 'Network error: Connection timed out' from Putty & can't ping it.

As far as I can tell the ATV2 is connected to my network as it has an ip address & can get to youtube etc. I just can't SSH into it.

Can anyone provide help? I've googled for similar problems but haven't been able to find an answer. Any help would be appreciated. I'm using win7 if that helps.

The latest version of Seas0nPasss will add a 'Seas0nPass' menu which provides visual confirmation that the AppleTV has been jailbroken successfully.

Do you see this menu on your AppleTV?

Hi James,

I can’t, as well, SSH my ATV2.

 

now I can :slight_smile: nothing like a reboot doen’t fix :smiley:

Hi - I’ve just JB’d my 4.3 Apple TV 2 using Seas0nPass and am experiencing the exact same issue as the OP - I can’t SSH in to the device.

On my main menu I have a little red SP icon in the bottom right hand corner of the screen so I assume the JB has been successful.

I’m running OS X Lion and have tried SSH via Terminal.app and Cyberduck to no avail.

Any suggestions? I’m pulling my hair out here…

I also need assistance.  I’ve successfully jailbroke the ATV2 (4.4) with seas0npass and do see the sp icon on screen, which I beileve indicates a successful jailbreak.  However, attempting to connect using SSH is unsucessful after trying all kinds of variations for connecting using root, device name, device IP, etc.  It always times out.  Then I tried to ping the ATV2 and was unsuccessful.  What do I need to do to connect so that I can upload other apps to the atv2 such as icefilms, etc.?

I’m a technical kind of guy, but am at a loss what to try next.

I also need assistance.  I’ve successfully jailbroke the ATV2 (4.4) with seas0npass and do see the sp icon on screen, which I beileve indicates a successful jailbreak.  However, attempting to connect using SSH is unsucessful after trying all kinds of variations for connecting using root, device name, device IP, etc.  It always times out.  Then I tried to ping the ATV2 and was unsuccessful.  What do I need to do to connect so that I can upload other apps to the atv2 such as icefilms, etc.?

I’m a technical kind of guy, but am at a loss what to try next.

I have had it on my 4.3 where all of a sudden I cannot ssh into it, yet it is still connected to the network. Restarting it did the trick.

Have you tried giving it a static IP address, just so you can be sure of the one it is getting?

GC32:  Before every attempt to utilize SSH, I check the IP address, which so far is always the same.  I guess I could reset the atv2 but then I’d lose my jailbreak, wouldn’t I? 

You wouldn’t lose it, you would just need to connect to your laptop and boot with SP again.

Nvm I figured it out…

Finally, successful jailbreak and xbmc installed. After the jailbreak the reboot of the avt2 did the trick and I was then able to install xbmc. Thanks for all your help!

I have Apple TV 2 4.4.4 9A406a. Followed all the instructions I can possibly find this completely.

Installed and ran Seas0nPass, got the little FC logo in the bottom right but cannot SSH. Timed out error. Reinstalled Seas0nPass, updated Seas0nPass. Ran the process three or four times. Plugged in my computer directly to the router. Made sure the router has AP isolation disabled. Cannot SSH, timed out error.

THen Downloaded SSH agent CyberDuck but same story.

Then tried PwnageTool but It does not recognize the IPSW firmware which i downloaded from three or four different sources but it says "AppleTV2,1_4.4.4_9A406a_Restore.ipsw" is not the right firmware. The apptv is updated and this is the newest firmware so it has to be correct? Can't even re jail break with Pwnagetool. :( someone please help out with this.

Lastly, I do not have an SSH folder to delete. Yes i have set up so that all hidden files are shown… actually how do i re-hide hidden files?

anybody please help me out! :slight_smile:

an

how do you reboot ATV2? Is it simply turning off the power? Or should i be doing something else. Like a tethered boot? I am so frustrated. Tried everything imaginable. any help will be appreciated. 

cheers

Inspiredlogic,

how do you reboot ATV2? Is it simply turning off the power? Or should i be doing something else. Like a tethered boot? I am so frustrated. Tried everything imaginable. any help will be appreciated. 

cheers

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!

Scotty, I have exactly the same problem.  Just finished jailbreaking 4.4.4 with the latest Seas0nPass.  Worked ok.  Got the FC logo and all. But now I can’t ssh into the ATV 2.  This means to NitoTV, no XBMC, no movies etc.  I’m so frustrated off.  I’ve looked everywhere for a solution and wasted countless hours.  I could scream.  I tried to revert back to 4.3.5 it won’t let me.  I’m completely stuck!!!

Firecore!  Help please!