Unable to share folders from a windows 2016 server essentials domain - RESOLVED

I bought the Pro version of the app yesterday to try out on my iPad. I am unable to logon to my server to get access to the share so infuse can play my dvds and blu rays ripped as folder structures from my server. The share is available to all PCs joined to the domain. I am the administrator of the domain and my credentials are correct. Infuse can easily connect to my htpc which uses Windows7 and has one share that is unrelated to media for streaming that infuse can see.

As another experiment I have tried to connect to my workstation pc which runs Windows10 with no success. So far I’ve tried SMB Auto, 1, 2, 3, and Legacy to connect to my server and all have failed. Legacy is the only one that came back with a meaningful error stating that it could not initialize a SMB connection. The others just stated that a error occurred with no explanation.

Hello, it’s related to security issues about smb v1 up to v3.
Better, try a nfs server on that windows server. Check this: http://blog.bobbyallen.me/2018/01/18/windows-server-2016-as-an-nfs-server-for-linux-clients/

1 Like

Hi,
Thanks for your reply and possible solution. In my use case, I discovered if I put in my servers ipaddress with my credentials, it immediately connects to the server share and the movies are available to watch. I have other PCs on my domain that are able to resolve the servers name, so this could be a issue with name resolution with infusion/server essentials 2016. It works fine in SMB auto or versions 1 through 3. I did try NFS but I ran into the same issue with name resolution. I didn’t go further into trying NFS using my servers ipaddress to connect to the share as SMB is working fine.

Using serveripaddress/sharename and using proper credentials if required will usually get around name resolution issues. Thanks for the link, but it appears that it’s not needed to set up an NFS server. His use case is different then mine, and that solution would over complicate my network when other systems I have in my domain are fine using SMB shares.

Are you using shortname or fqdn? I’ve run into issues with iOS devices sometimes not resolving short names.

I’m using a short name. That could very will be the root cause.

I’m happy that I was able to resolve this. I want to be able to get rid of my Tivo and HTPC once silicon dust releases their Tv app for Apple TV. That would allow me to use thier network cable card tuners, have access to my own library of media, and access to the Apple TV eco system for prime, Netflix, Hulu, etc. it’s the one box to rule them all scenario, but that topic is for a separate thread.

It depends on who is the dns server. if you have external dns pushed by isp router you might have problems resolving dns names inside your network.
You might try adding the DNS server role on your Server 2016 and use it’s ip address on all internal network devices including atv 4k. Secondly, in DNS Server you can map static dns addresses to ip addresses if you still have issues.

The primary DNS is the server, and it has a static ip. Secondary is the router which allows me to get out to the internet when I have to bring the server down which is rare. Essentials 2016 or any windows server (except for WHS 2011 which only runs as a workgroup) for that matter runs as a domain by default when it’s first setup. My iPad using infusion specifically that has been the only one that has had this issue. When I have some more free time, I’ll look into it further. Right now it’s working, and I can watch a movie from my iPad. :slight_smile:

He should have internal DNS as he mentions running a domain so this is added during the domain prep. The other is internal domain name might not be pushed out as an option in dhcp.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.