Unable to play without huge buffering issues (Synology NAS, Chromecast Ultra, iPhone Xs)

Hello!

Here’s the setup:

  • Synology DS218+ (source)
  • Chromecast Ultra (playback device)
  • iPhone Xs where Infuse sits

Synology and Chromecast are connected via 1Gbps wired LAN.

Almost any file I try to stream on the Chromecast buffers constantly.
I have no playback issues directly streaming from Synology to iPhone. Works like a charm.
But streaming to Chromecast simply fails. This is been going for some 9+ months now.
What gives? I’m puzzled because I have a robust LAN (1Gbps) - and all other playbacks on Chromecast are working without problems (Netflix, Disney+, …).
Oh, and this is important, same content (Synology+Chromecast) plays without issues via VLC iOS app, so it’s definitely some Infuse-specific issue.

Welcome to the forum!

You may want to go through the users guide and see if it may have some pointers on how to set things up.

1 Like

Nope. What’s troubling me the most is that casting through VLC works with whatever I throw at it (different MKVs, from 720p to 4k, doesn’t matter), but Infuse almost immediately starts buffering when a video starts. :slightly_frowning_face:
Don’t know what’s going on…

What do you have selected in Settings > Playback > Streaming Cache?

You may want to try Legacy to see if that helps.

What protocol are you using for the share? SMB, NFS, FTP, SFTP, UPnP, DLNA, or WebDAV?

Same here. In my opinion, this was introduced with the „ultra-optimized streaming cache“ in version 7.3.7 of Infuse. Prior versions of Infuse were running just fine with no buffering issues. The problematic files are running buttery smooth with VLC Player on the same device (iPad) and on the same wireless network.
See my thread „Severe playback issues. Constant buffering“ under Platforms—> iPhone & iPad.

Unless you’re using chromecast this isn’t the same as your problem.

If you read the original post you’ll note

Tried all 3 Streaming Cache options (Auto, Memory Only, Legacy) - no change. Buffering still present.
Tried changing all SMB options (from Auto to SMB3, then SMB2, SMB1, Legacy) - no change. Still buffers. :confused:

I repeat, the buffering issue occurs only when casting (media from Synology) from iPhone to Chromecast Ultra.
When playing directly the same media on the phone itself, everything works OK.