Unable to play media from my NAS

Well i’m here hope to find a solution to the “Playback error - An error occurred loading this content.”

Set-up:

I connected my media rich external HDD’s (750gb and 1tb western digital my passports) to the iomega iconnect wireless data station to convert them to network attached storage. I found the device, and am able to view all content and metadata is downloaded but when I select any of it it gives me that ^ error. Regardless of what file it is avi mkv mp4 m4v.

maybe plex could be a solution but i’m not sure how it exists.

questions just ask.

Not sure if this will help, but when I’ve encountered this error ut’s had to do with the audio. Try changing the Dolby Digital setting in the Apple TV to auto or On and see if it plays with either of those settings.

I have the same problem. changing the audio-settings is not the solution. Some more ideas? No one else with the same problem?

(Buffallo NAS-Server - different video files like mkv, dvd, avi …)

Hi,

i had this problem in the past. The problem on my WD May Book World Edition was that i used the AFP Service to connect to my shares. But after i changed it to SMB all files worked well and i never had any problem.

changing the audio settings don’t work. How do I change it to smb?

 

Add a new share in the settings and choose some from SMB not AFP

In my case it is allready linkes per SMB. That’s also not the reason :frowning:

I’m returning the iconnect for a pogoplug series 4 so won’t be able to trouble shoot this for about a week. BUT i changed it to smb and that didn’t work either…

 

hmm so best thing is to open an support ticket and maybe you are able to give firecore a sample too. Or maybe you can give us a sample?

What “Sample” you are thinking about?

  • AppleTV2 (Black)
  • NAS Server Buffallo Linkstation
  • linked per SMB
  • Audio configured as Auto
  • no DVD Folder / no mkv / no avi is running

I will create a ticket

I originally had problems playing .avi & .mkv files from my Buffalo TeraStation via SMB;  I was able to connect to the SMB share but playback would stop unexpectidly soon after starting playback.     However I was able to upgrade the version of Samba installed on the TeraStation from the original version 2 Samba to a newer version 3 Samba.     In my case this solved my playback problems.

I suspect therefore that some of the reported problems about playing back video from NAS boxes (such as from a Buffalo LinkStation) may be related to the version of Samba on the NAS box and how the MediaPlayer interacts with it.    Whether this is a speed issue (the version 3 Samba is noticably faster than the version 2 Samba), or some other subtle difference between the SMB protocol implemeneted by different version of Samba I don’t know.