Unable to play DVD Files

I have the latest build of ATV Flash installed on my ATV and I am unable to play DVD files with NitoTV. These are files that once-upon-a-time, before Apple sent out updates from 2.1, worked fine. The movies are stored on an external drive in a DVD sub-directory. Each Movie has a title folder, which in turn contains the VIDEO_TS folder and its contents. Whenever I use NitoTV and select a DVD to play (NitoTV -> Files -> Select DVD Directory -> Select specific DVD) I get a menu option to “Play Title”. I select this and the screen blanks out for a couple of seconds, then returns to the “Play Title” menu. I have tried turning “Straight to Menu” off, which only makes for a more confusing mess. I have also tried changing the setting for File Playback mode to mplayer, quicktime and mixed modes without any noticeable changes. I have gone through the install software menu to insure that the latest versions of all software and drivers are installed. Any suggestions ???

have you upgrade to 3.4.3?, Mine plays fine but still there are a few problems