Unable to partition

Hello,

When I try to create the USB Flash drive, i’ve got an error : “Unable to partition. diskutil returned 1”.
My OS : Snow Leopard 10.6.2
Please Help !

Thanks

Sounds like it could be a flash drive issue. Do you have an alternate drive you can try?

Hello,

Same problem even using two different drivers

Thanks

I have exactly the same problem. Anyone know of a possible workaround yet?

I am using the same patch stick that I have always used. I have since formatted it to FAT32 and now back to the mac format.
Never had this problem prior to 4.0.5 and moving to snow leopard, one of those seems to be causing diskutil to fail.

What size flash drive are you using for the install? Also, you may want to ensure you are selecting the USB flash drive from the list, and not the aTV Flash disk.

Yep, I am getting same issue here and there is nothing wrong with the USB - it is an ATV issue 100%.

I am having the exact same problem with 2 different flash drives. When I installed ATV Flash a year ago, I had zero installation issues - now I can’t even prep the flash drive (and haven’t heard from ATV Support). Can anyone please help here?

You may try formatting your flash drive (including the optional step #4) as described here: http://wiki.atvflash.com/index.php?title=Troubleshooting#My_Flash_Drive_No_Longer_Works_After_Installing_aTV_Flash

I was having either the partition problem or the unmount problem, but finally got it to work. I am using a Mac with Snow-Leopard 10.6.3.

If you have been having this problem, you probably downloaded the ATV image file using ATVFlash. In my case it was in the downloads folder and called “latest1270326119662.dmg”

I am not sure if this will work for everyone, but here are the steps that worked for me:

1.) Reboot the Mac using safe boot (hold down the shift key immediately at restart).
2.) Launch Disk Utility (applications/utilities/disk utility)
3.) Erase the USB Flash with Mac OS Extended (journaled). I zeroed all the data for good measure.
4.) Open the downloaded ATV image so the OSBoot drive shows up in your volumes
5.) Close Disk Utility
6.) Run ATVFlash. It hopefully will go through the entire process without issue.

The install worked fine provided my Mac was booted in safe mode and the ATV Image (OSBoot) was mounted before I launched ATVFlash.

I decided to try booting in safe mode after seeing programs that watch the file system (like Clean My Mac or CleanApp) were spiking in the Activity Monitor. I figured it was worth a shot to reboot with just the base OS running. My un-educated guess is that some other process on the machine is preventing ATVFLash from doing what it needs to do with the Disk Utility.

Hope this allows other people to get up and running.

worked fine thanks Tumbledry.

I did it!!

Don´t know how but i went to the “ACTIVITY MONITOR” and close the U3 Agent and at the same time was making the USB with the ATV Flash. Finally!!

Hope it works to everyone. Very happY!!!

See Ya, I´ll never update before looking at this forum

I wrote a wrapper for diskutil to see what arguments it is being called with.
I get

diskutil list

for when it is enumerating the list of disks and then

diskutil partitionDisk /dev/disk4 1 GPTFormat HFS+ Patchstick-root 214M

when it tries to format. I executed the same from the command line and got a

214M does not appear to be a valid disk size

error message. Still playing with working out what that means

which means that the USB stick that I am using is too small. Used to fit onto this stick, but seems that it does no longer.

Hi,

I have the same error!!

I try :

Sandisk 256 MB
Kingston 1 GB
Sony 4 GB
Sandisk 8 GB

And I have the same error Unable to partition! Please help me!!

Thanks

If you’re having trouble installing please send an email here: http://www.atvflash.com/contact.php

Had the same problem but found out that cleanmymac was the culprit on my computer!
If you have the said software installed, go to preferences and disable automatic trashes and osx service junk cleanup.

thanks very much everyone! :smiley:

*particularly deanan… was my issue too.

jt :slight_smile:

It seems there is a conflict with some features of ‘Clean My Mac’. This issue should be resolved in the upcoming version.

This approach worked for me too.  I am not sure if it was the starting of the Mac in "Safe Mode" that was key or the mounting of the OSBoot image prior to starting the "aTV Flash" application.  Anyway, it worked.  

 

Thanks for posting.