Unable to mount external drive

I'm at my wits end.  I'm unable to mount an external drive to the ATv.  I've come back to this after about 6 months as it wasn't solved back then and I'm tired of having to delete a file every time I want to add a new one.

I've looked through the forums and tried many of the solutions but to no avail including

Running the smart installer many times

deleting the dmg files from documents

Un installing the NitoTv app and re-installing.

Each time I run the Smart Installer I get the following

Install Partial or failed

...root filesystem already writable

...kextloader already installed!

...mach_kernal.prelink already patched or unrecognized

...bins installed successfully!

...no files to install, returning

If I try to make the storage external I'm told there is no drive connected or to run the smart installer...

I've tried using two different drives both mac extended journaled 

The only thing i haven't done is return to factory settings because my library isn't currently sunk to a computer so i don't want to loose all my itunes content.

Any suggestions or solutions appreciated.

Thanks

Which versions of AppleTV (Settings --> General --> About) and aTV Flash (Maintenance --> About) are you currently running.

What type of drive are you attempting to use?  Do you know the drive format?

 Currently running ATV 3.02 and ATV Flash 4.2

The two drives I have tried are as follows

ioemga 1.5 TB OSX extended journaled.  Set up a folder MY MEDIA in it there were 2 Folders MOVIES & TV

Seagate Free agent 250GB OSX extended journaled.  This drive has other files on it so wasn't completely empty.

Both drives were formatted with a mac OS extended journaled.

Should I try a factory reset? How would you suggested I back up my itunes ATV library if I was to do a factory reset?  Can I sync it to an external drive plugged into a mac?

Thanks

 I've since tried yet another drive, this one is a Seagate Expansion 1TB Mac OS journaled.  Still doesn't show up and the smart installer is saying the same thing.

Are you using any type of USB hub? Are the drives being connected before or after the AppleTV is powered on?

 No hub is being used, tried the drives both before and after the ATV is plugged in.

Currently I'm transferring all the itunes purchases to a drive through Cyberduck with the intention of doing a factory reset and then putting ATV flash back on unless you have any other suggestions?

 

make sure the drive is formated as apple HFS+ you will need to use the trial version of MACDRIVE or any other equivalent tool that will format a USB drive as the apple HFS+ file system.

you also need to set the drive under apple tv as external, to get itunes to write the proper file structure to the drive. then set the apple tv back to internal drive.

everything works after that.

I think atvflash should provide some kind of windows drive format tool for your usb drive. But the trial version of MACDRIVE does that.

you can use exFAT as the drive format under Windows. works fine, as NTFS does not work.

I formated my drive as exFAT and it attached to the Apple TV Gen 1. Switch to external USB drive, in Apple TV, which caused a format of my USB drive again. Then switched back to internal drive.

Attached the USB drive back to my windows 7 machine and now it is HFS+ format.

Weird, but I still have function with HFS+ files. As I have a driver that will work with that under windows 7.

I'm doing the initial setup today. My 1TB external Western Digital (with all of my DVD media) is currently formatted as Mac OS Extended (Journaled) and the ATV is not detecting it.

Am I to understand that it should be reformatted as HFS+?