Unable to Jailbreak ATV2 - vfdecrypt failed

Need help!

I am trying to jailbreak my ATV2 using my Mac (10.6.8) and Seas0nPass 0.8.6 (565)

When creating the custom ipsw, I am always stuck at the “Patching Filesystem”, 

The logs say

8/19/12 PM 12:13:08 Seas0nPass[417] performed patches successfully!
8/19/12 PM 12:13:10 Seas0nPass[417] patched ramdisk successfully!
8/19/12 PM 12:13:10 Seas0nPass[417] firmware patches successful!
8/19/12 PM 12:13:10 Seas0nPass[458] *** NSTask: Task create for path ‘/Users/break1/Desktop/Seas0nPass.app/Contents/Resources/bin/vfdecrypt’ failed: 22, “Invalid argument”.  Terminating temporary process.
8/19/12 PM 12:13:13 ReportCrash[459] Saved crash report for Seas0nPass[458] version ??? (???) to /Users/break1/Library/Logs/DiagnosticReports/Seas0nPass_2012-08-19-121312_one-mac-mini.crash

Have tried even after repairing file system permission.
Any help is very appreciated.


thanks in advance 

Filevault is turned off 

I’m having the same problem. Is there any update on this?

No luck so far. Still waiting for a solution.

Switched to a different machine and it worked fine.
Guess there must have been some file/permission issue with the original mac i was using.