Unable to Install aTV Flash (Black) - "Sorry, the installer could not connect to your Apple TV"

After several attempts of using Seas0npass to jailbreak my ATV2, I gave up as I could never get it into DFU mode.  Tried and tried but no luck. Tried using sn0wbreeze-v2.5.1 and after 1 attempt got it to work.  So...my ATV2 is now JB using 4.2.1 firmware (AppleTV2,1_4.3_8F202_Restore) and I can see the NitoTV menu now.  I've looked around and it appers that the SSH component is installed and ok.  I ran through the NitoTV update as well just incase.  I went to install aTVFlash-black installation file (downloaded from my Firecore account on 06-MAR-11) and started the installation. My Apple TV shows up as an available device with the IP address...i click next and it gives: 

"Sorry, the installer could not connect to your Apple TV. Help!"

I tried to SSH into my Apple TV using instructions from : http://support.firecore.com/entries/316002-connecting-via-ssh-and-sftp.

But couldn't connect...so for some reason SSH is not working.  Any thoughts what to check to get this going.  I really want to use the aTV Black after paying for it 2 weeks ago.  Still haven't been able to get it installed.

 

Any help is appreciated.

DId you check the dropdown on the ATV installer to see if there was more than one item listed? Mine for some reason showed two ATV's with unique IP addresses, no idea why I only have one Apple TV. The first and default item in the list gve the same error you got the second item in the list worked fine.

Also I noticed during install the installer got the "wheel of death" but just leave it and after a few minutes it should be ok.

Yes. The drop down only shows one ATV in the installer.  Checked it again tonight and it still won't install.  When i try to connect using Cyberduck it gives the following error:

 

Connection Failed

No connection could be made because the target machine actively refused it 192.168.1.143:22

 

 

Experiencing exactly the same issue. Any solution?

Same problem. Help please....

I have the exact same problem. If someone know the answer, please response. Paid for the software but unable to use it. Slowly my excitement is wearing off

If your jailbreak is successful and you can make a SSH connection to the ATV, then you can use the alternative install method of running the install from the ATV end.  

Please explain how. Tried everything - windows user. Even firecores guide. Jailbreak went without problems, but how can I control, that it really is ok? 

the same problem not working at all HELPPPPPPPPPPPPPPPPPPPPP...

we use windows not mac ...somebody help me out........ :( :(

Same issue here!! Please help otherwise we have wasted our money.

If you're receiving this message, and are unable to connect via SFTP or SSH that usually indicates your AppleTV is not currently jailbroken. Your best option will be to re-run Seas0nPass to jailbreak the AppleTV.

Download the latest version of Seas0Pnass here.

Some general troubleshooting tips for Seas0nPass can be found here.

I have  the same  problem    is there a  Fix out there

If your ATV2 is in sleep mode (you have not used it with the remote for a while) then nothing will allow a connection.  I have seen this happen on mine.  Then I wake up the ATV2 and can connect.  Have not seen anyone mention this yet.     Also make sure you start with the latest version of ATV2 sofware already installed and working from the ITUNES linked apple web site.  You should have restored to the latest version of software from apple first.  Then SEASONPASS will work.