Unable to connect to iTunes store

My ATV2 is jailbroken and at iOS6.2; my goal is to enable Now TV, which wasn’t showing on my menu.

After much reading of the forum I changed my info.plist file, updating the relevant fields from 5.3 to 6.2 and rebooted. Now TV duly appeared but I wasn’t able to buy a Sky Sports pass, nor was I able to buy anything else anywhere on the ATV, including a show from the iTunes store (not surprisingly I guess). When I changed the plist back, happy days, the iTunes store worked, but of course Now TV had gone from the menus.

I have since tried using 6.1.1 in the plist fields and whilst Now TV appears, nothing other than the original configuration allows me to connect to the iTunes Store.

This is, obviously, not a Now TV issue, so that can be ignored as a red herring, but can anyone point me in the right direction? I have tried all the “obvious” such as resetting the network settings, removing iTunes accounts and reentering them, powering the ATV off (I always rebooted after a change of plist) and on again…now I am out of ideas.

Can anyone help me?