Unable to connect Infuse 7 iMac to NAS

Setup:
Infuse 7.0 (7.0.3582)
USB-drive > iMac > AirPort Extreme > AppleTV > Infuse: works fine.
USB-drive > iMac > Infuse: works fine.
NAS > AirPort Extreme > AppleTV > Infuse: works fine.
NAS > AirPort Extreme > iMac > Infuse: does not work.

The NAS shows up on Saved Shares, but throw an error while trying to connect. After choosing Forget this Share, the NAS reappears on Available Shares but I’m still unable to connect to it. The Favourites placeholders from the AppleTV do show up on the Files tab, but throw the same error.

If its a WD NAS, check if there’s an OS update. I had this same issue on one of the 7’s beta’s using a WD NAS - same scenario’s you’ve described. On the final beta, it worked - but by then I’d also updated the OS for the NAS prior to testing again (there was a new OS5 update last week).

Thanks, but it’s an Asustor AS6204T current on updates.

1 Like

Have you tried FTP ?

I use a no frills outdated Lenovo NAS and infuse finds it’s FTP shares. With my ATV4K it tested 10x faster than SMB.

Just did: “An error occurred”.

Sounds like a configuration of the router problem to me. I don’t know all about airport extreme.

If you can submit a report from Infuse on Mac (Preferences > Email Us) and post the 5 digit code it gives you then we can look into what may be causing this.

Diagnostics: 0DZ2X. Email sent. Thanks James.

It looks like Infuse is getting a series of ‘share unavailable’ messages.

Are you using multiple Wi-Fi bands/networks? If so, can you try switching bands to see if this has any effect? We’ve seen some cases where devices are available on 2.4GHz but not 5GHz (and vice versa).

All connections are wired…

Success! The trick is not to use the NAS from the Available Shares, which has the address field prepopulated with only the name of the NAS (not editable).
Instead use the Add SMB option, where you type the name of the NAS and add .local (which seems to be required).


3 Likes

Great! Thanks for following up. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.