UI freezes when adding Emby share

I know, that’s quite the clickbait headline, but hang on a sec while I unravel this tangled tale. So recently, I updated Infuse to version 7.7, and here’s the thing: whenever I try adding an Emby URL, the app automatically switches my connection protocol over to WebDAV (HTTPS). But when I manually switch it back to Emby, boom, my device locks up, and the only way out is by hitting the return button for a hard reset.

In an attempt to fix this, I tried syncing through iCloud, but turns out, my iCloud storage was bursting at the seams. So I called Apple Support, and with their guidance, I had to turn off photo sync in iCloud. As a result, bam! There go my 1500 cherished memories.

Now, I’m nursing a bittersweet sorrow, hoping against hope that Apple’s top-notch support team can somehow pull off a miraculous recovery. And irony of ironies, despite all this, I still haven’t managed to add Emby to my TV properly.

I’m sorry to hear about your photos, that is a huge bummer. :confused:

We are looking into an issue that can arise under certain conditions when trying to add an Emby share. This is not related to iCloud and can also be reproduced in 7.6.7, so it doesn’t seem to be something new that was introduced in 7.7.

I’ve updated the thread title so in case other users run into the same issue.

I realize this has nothing to do with iCloud directly, because I can’t add it on the TV end. So what I’m trying to do now is sync my media library using iCloud. Sorry for the clickbait-y title, but it got your attention, right? Please prioritize fixing this issue because, well, I’ve already lost 1500 photos here, and on top of that, I haven’t sorted out adding my media library yet.

So, here’s the deal. I haven’t done any special settings on my TV; all I did was download the app onto it. Right now, I can’t seem to add a single Emby media library because of this pesky bug.

I’ve tried everything under the sun – deleting the app, uninstalling it, you name it – but no luck so far. Also, I previously reached out through a friend who messaged you in our group, and from where we stand now, it looks like we’re still not over this hump.

The workaround for this right now is to avoid including the https (or http) portion of the address when copy/pasting in the Emby address.

EG

Instead of: https://serveraddress.com

Use: serveraddress.com

Or just type in the address manually without the http(s).

Really appreciate you taking the time out of your busy schedule to provide a solution. I’ll give it a go later on and will definitely update this thread with how it goes. Fingers crossed, hoping this issue gets resolved in one of the upcoming versions soon.

Sure thing, following your method, I can currently add Emby, but getting Aliyun Cloud Drive connected is still a no-go.

Aliyun Drive (and other cloud service) connections can be made on iOS/macOS and will then sync to the Apple TV via iCloud.

This issue has been resolved in today’s 7.7.2 update. :slight_smile:

Thanks for your patience.

Hey there, really appreciate the heads-up! I’ve downloaded it and noticed some issues. I’ll get back to you with my feedback shortly.