tvOS & iOS SMB share skipping/jumping

Hey there,

My first post so don’t kill me.

I have a TrueNAS ZFS array sharing iSCSI block storage to my Windows Server 2019 File server. My file server is sharing SMB to my various devices, on LAN, speeds are ~550MiB/s, Wi-Fi is around half that.

I don’t know what may have changed, but I noticed just today that videos whether Movies or TV Shows display the same issue. Essentially, after 10-30 seconds of playback, the video will jump forward to a random place whether a few seconds or minutes later. Skipping to go back results in the video going even further forward, unless if you skip back to the beginning.

My media is transcoded to MKV and has always played buttery smooth. Is anyone else experiencing this?

Ive tried using framerate matching in case there was some issue with tvOS and 4k or something, but then I noticed my phone did this too. So I tried using DTS instead of DTSHD audio, as well as no subtitles; they all exhibit the same issue.

Feedback is greatly welcomed!

1 Like

Welcome to the forum!

Just out of curiosity, have you tried a different player like VLC on the same videos?

Is it always the same time in the video it starts and jumps on both ATV and iOS device?