tvOS 16 audio sync?

I have tested the latest beta today. The sync issue is improved but still exists.

On the 23.976fps test files, the delay has gone from -4 to around -2. The 30fps test file is still OK at 0.

I can set the audio delay to 80ms on affected files to get them in sync, but it’s not ideal when the -2 delay isn’t universal.

Diagnostics: YE74E

Hi @james. Have you been able to report the underlying tvOS 16 bug to Apple? This appears to be such a niche issue I fear it may never get addressed by them, since I expect they’ll get very few reports due to ‘core’ media consumption apps (Netflix etc.) not demonstrating this issue.

1 Like

@james I ran the test video AVSyncTest again with the beta. Here are the results:

  • Code 3QQ38
  • -2 frame number
  • 1080p @ 50hz with Match Content is ON (projector switched to 23.976 for the video)
  • Audio via HDMI into DAC (as before)
  • Video via HDMI to projector (as before)
  • Apple TV HD (IOS 16.0)

It is an improvement but not quite there for me.

You may want to update to 16.1 just to cover all the bases. :wink:

Yea I figured it would’ve upgraded by now but saw after the test it hadn’t. It’s updating now.

1 Like

7.4.7 is now publicly available on the App Store. This includes the sync fixes (which have resolved issues for a number of users), and a manual audio delay option.

If you are still seeing any sync issues after installing 7.4.7 we would like to collect the following info.

  1. Which sync test videos are causing issues?
  2. Type of audio output (AV receiver, HomePods, TV speaker, etc…)
  3. Is Wireless Audio Sync enabled?
    a. If enabled, please try disabling to see if there is any effect.
    b. If not enabled, please enable and follow the activation steps. Note: Some users have reported the sync steps need to be repeated for each refresh rate (EG 50Hz, 23.976Hz, etc…) you plan to use. To do this, switch the video output manual to a specific refresh rate (via Settings > Video and Audio > Format), and repeat the Wireless Audio Sync steps.

If the issues persist after adjusting Wireless Audio Sync, please submit a new report and post the code here.

4 Likes

Still using Yamaha AVR with activated match framerate on:

  • Preferred test file “AVSyncTest” : old -2, with 7.4.7: 0 perfect in sync now
  • “AAC sync test”: old was perfectly in sync, with 7.4.7: +1 audio 100ms too late
  • “DTS 5.1 sync test”: old -4, with 7.4.7: -1.5
  • “Dolby 5.1 sync test”: old -4, with 7.4.7: -2

Well this is not what I would call a fix. It makes it even worse since you have now a situation were some files (with AAC) got you too early video and not audio as in DTS and Dolby.

Fine that PCM audio (Core Media Audio) is now perfectly in sync but in the field nobody uses this audio format…

I appreciate that you guys try to workaround Apples mess but seriously how do you test in development if it outputs synchronous audio/video? Please someone at Firecore has got an up to date iPhone so that you can test at least with the SlowMo 240 video function!? Thanks.

Edit: I do not use (and never have) the wireless audio sync feature.

Here are my measurements for 7.4.7

  • PCM Stereo (AVTestVideo): -2
  • AAC Stereo: 0
  • Dolby 5.1: -2
  • DTS 5.1: -2

Audio output is HDMI into DAC

No wireless Audio Sync

Code 2E3VC

==========

EDIT: I did some more testing out of curiosity:

1080p @ 50Hz with match frame rate ON (same as above - added for clarity)

PCM Stereo (AVTestVideo): -2
AAC Stereo: 0
Dobly 5.1: -2
DTS 5.1: -2

1080p @ 23.976 with match frame rate OFF

PCM Stereo: -2
AAC Stereo: 0
Dolby 5.1: -3
DTS 5.1: -2

1080p @ 50hz with match frame rate OFF

PCM Stereo: -4
AAC Stereo: 0
Dolby 5.1: -2
DTS 5.1: -1

How do you get to 100ms here? 1 frame is 41.7ms.

EDIT: never mind this file does 10th of second measurements :slight_smile:

1 Like

So you hear your sound not via the build-in TV speakers, right? If so, bear in mind that you need somehow somewhere in the chain an “offset audio delay” because your TV needs time for its image processing. For example mine needs 70ms. If you did not consider this (and this is for everyone here) every measurement is incorrect.

I know there is HDMI auto lip sync out there but most TVs does not implement this or it just does not work correctly.

If you got an AVR or similar it is easy to adjust this delay:

  • Disable all audio delay settings in your TV menu (set it to 0ms).
  • Enable TV speaker and AVR speaker so you hear the sound from both.
  • Now adjust the audio delay in your AVR until the echo is gone.
  • Save this delay in your AVR as default.
  • Disable TV speaker and or disable HDMI audio output in your AVR.

Hope this helps some people here. Not every lipsync issue is caused by Apple and/or Infuse. Just saying :slight_smile:

1 Like

Correct. It is even a projector. But it is a gaming projector with a latency of 16ms (factory spec).

Netflix has audio sync test videos as well and I verified that there is no delay with Netflix so I am pretty confident in my measurements.

It is a fair remark though and good advice!

It’s all very well setting the delay on your AV receiver, but that doesn’t help when no other apps or other sources have lip sync issues, or when the sync delay in Infuse varies according to the played content.

In that scenario it would be better to use the new audio delay adjustment feature in Infuse on a case-by-case basis.

I really hope the next updates got some better solution. Otherwise this is a really bad user experience if you have to slidy slide that delay slider thingy every time you switch between AAC and Dolby or DTS files… And do we even know for certain if the audio format is the only variable here or is the source resolution also a problem?

In my experience the audio format isn’t the issue, but the resolution and/or the frame rate.

Any file that is 29.97/30 fps works fine on my system (including the AAC test file).

4K files seem to work fine (all 23.976 fps).

Basically, anything that isn’t 4K or 29.97/30 fps has sync problems, although the latest update does improve matters.

Well, I’m happy to say that with the latest version, the problem is gone for me. (At least so far. Been checking a few specific files which had issues before).

Hi James,

I am still experiencing sync issues, although less severe than before.

In answer to your questions:

  1. All sync test videos suffer a delay of between -2 and -3, except the AAC 30fps video which is 0.

  2. Audio output is Denon AVR-X3400H receiver.

  3. Wireless audio sync does not appear to help. I calibrated in both 4K 50Hz and 1080p 23.976Hz modes, but the test videos were still out of sync.

I submitted a report the other day with the latest beta: YE74E

If you would like me to submit another report with the latest public release, please let me know.

Infuse version 7.4.7 has appeared to resolve the issues for me playing through Apple TV > Denon Receiver > Samsung TV

Cheers

1 Like

Opposite for me. I took a chance on 7.4.7 tonight… wish I could revert back to previous. Looks like particularly h.264 1080p blu-rays now look really out of sync - was so much better on previous rev with frame rate match off.

I’ve had to skew the audio about -150 or -200 ms now to make it watchable. wife keeps telling me, if it ain’t too broke, don’t mess with it…

If you have a chance this may help.

Except it was pretty broke… so it needed fixing.

The new version of Infuse has seemingly fixed the audio sync issue for all videos I’ve watched so far. So, thanks Firecore!

1 Like