TV Shows not grouping

Hi there, I just bought InFuse and loving it so far, much better than the Kodi versions I’ve been using previously.

There are some issues I’m trying to work out though.

There are some tv shows that aren’t grouping, but showing up as folders instead, no thumbnail and sorted on top of the list. Going in, the file names all work out and the seasons are grouped within it, however the parent folder always shows up in the root as a normal folder.

For some shows, there’s only one season available, so they weren’t grouped by season in it’s folder, they show up with thumbnails, but their title is “Season 1” instead of the shows name. Going into the folder and grouping the files into a season fixes the problem, but for some shows, the previous problem occurs. The show folder shows up as a normal folder without a thumbnail but files are grouped into seasons within it.

I’m using the same recommended folder structure for every show

Show name

  • Season

I have the same issue. I haven’t been able to discern the exact logic Infuse is using to turn a folder into a TV Show item, and what kind of content structure it’s look for.

I had some initial problems, but I renamed my files (I had some that were weird) and that fixed it in most cases. I a few that still didn’t work I simply edited the data on one of the series, selected the correct show from the\h search, for example The Librarians, and the app was smart enough to read the change and apply to all of the other The Librarians episodes in the same directory.

This also helped when Infuse chose the work show. In my case the Battlestar Galactica show that I have was incorrectly identified as the 70s series instead of the Ron Moore series. Once I searched and selected the correct one it corrected all episodes in all directories under the main Battlestar Galactica directory.

Hope that helps.

I’ve renamed all the files that were odd, so they all have the same file naming convention. They’re correctly grouped into seasons with a thumbnail. It’s just the parent folder that remains a normal folder.

I have had the same issue with some parent folders not showing the art work or description even though the season folder inside has the right metadata and the parent folder has the exact same name.

I have noticed that if the name isn’t exactly right it won’t recognise the parent folder. This is a real pain for tv show with colons in the title such as Star Wars: Clone Wars etc as I can’t name the parent folder the exact same name.

Firecore can you fix this issue with the parent folder and colon issue

This makes no sense be cause in the iOS version files that I just uploaded with no structure grouped fine and now in TV version it can’t even figure out what they are. It is labeling them as Movies and not TV Shows. Seems to be taking the episode title and trying to match that with a Movie title. For example the Futurama episode “The Roomate” doesn’t have data for a Futurama episode but for a 2011 movie called The Roomate. All these files work perfectly in the iOS app.

There is a metadata sorting thread check there, it will probably resolve 95% of sorting issues.

interest stat (i.e. 95%), but not true, doesn’t resolve my issue or many of the others mentioned here. But thanks for the glib solution Ghill

I have the same problem with two shows. I solved it by adding a folder.jpg manually to the root folder of those shows.

Same “Season 1” issue here. I still have an aTV2 that parses the same drive correctly, so I would like to avoid renaming everything, assuming I even know what to rename them to.

Same issue here, multiple seasons under a parent folder = no parent folder artwork.
Single season under a parent folder = parent folder artwork

Please help firecore, love this app apart from that.

Reading through that thread helped me, had to have everything as:

Series Folder > Season Folder > Episodes

Dates in ep titles messed up a few too.

If you make even single seasons into a Season folder it puts the ordering correct.

Now i need to figure out what to do with empty folders, ill ask in the meta data thread.

Hrellir, the resolution in this topic should resolve your issue. →

Please return with info about that.

Hrellir, the resolution in this topic should resolve your issue. →

Please return with info about that.[/quote]
Happy to report that this worked like a charm.

Hrellir, the resolution in this topic should resolve your issue. →

Please return with info about that.[/quote]
Happy to report that this worked like a charm.[/quote]

Great!! It also worked for me. :smiley: