TV series no longer playing smooth on AppleTV v7.5 (4382)

Hi all, for the last week I’ve been watching a TV series encoded as 4K HRD10 with an Atmos soundtrack. The first 4 episodes played back smoothly, but when I went to play the 5th last night it was not great. I saw

  • Skipped frames.
  • Ghosting and incorrect colour for the first 10 seconds or so.
  • Sometimes sections of video getting out of place. ie. A second of two of video from a few seconds in the future playing ahead, out of sync with the audio.


  • Restarted everything.
  • Changed various settings on the AppleTV.
  • Reset the AppleTV’s video settings.

Then I tried playing the first 4 episodes again, and they wouldn’t play smoothly anymore.

Then I realised the problems had started after Infuse updated from 7.4 to 7.5 where they did some work on the video code.

So now I’m thinking there are some playback issues in 7.5.

Anyone else seeing problems?

Yes, I noticed similar issues when we start a movie or make fast forward/reverse.
I have ATV 4K gen 1 and 3. The issues happen only on ATV 4K gen 3 and HDR movies.

Would you be able to upload one of these problematic files for us to review here?

2 files were uploaded.

I can see all HDR movies having similar issues more or less at start or fast forward/reverse. The videos have been “frozen” for some seconds while audio still went on. DV movies seem to have less issues. Ghosting sometimes appeared. The issues seem to be at ATP 4K gen 3 only, gen 1 is ok

2 files uploaded.

I’ve uploaded some samples as well. However for me, the issues are on a 4K Gen 1 Apple TV which has the A10X Fusion chip in it.

I have experienced a similar issue on Dolby Vision files after the update to 7.5.0, where playback sometimes skips or pauses for a few milliseconds. Not very long, but long enough to be noticeable. Happens every 10 seconds or so.

The audio is unaffected; it is only video that is doing this.

I changed the setting “Extended Dolby Vision” to “Off”, and this fixed the issue. However, the files are no longer played back in DV of course. Tried to set it to “Limited” at first, but this still had the intermittent skips.

We believe this should be resolved in today’s 7.5.3 update.

This update improves support for files which have missing or invalid mastering metadata.

Please let us know if you continue to see issues here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.