TV Metadata Not Loading for Judge Judy

Hey, longtime fan and user of Infuse here!

I’ve encountered what seems to be a bug, and I’m curious if anyone has any solution. I recently added a bunch of episodes of Judge Judy to my Infuse library, and I can’t get the metadata to load correctly for any of them.

The show exists on thetvdb, but regardless of how I name the files, they will not use the metadata from thetvdb

What’s more, if I long-press on an episode, choose “Edit Metadata” and specifically choose “Judge Judy” from the list of suggestions, Infuse still doesn’t update with any of the metadata information.

I’ve added hundreds of shows to my Infuse library over the years, and I’ve never had this issue happen before. Any advice?

Can you provide an example of how you have the files named?

I’ve tried several naming schemes, none of which seem to make any difference.

My go-to naming is “Judge Judy - s6e1 - TVRip.mkv”, but I’ve also tried “judge.judy.s6e1.mkv” and “judge judy s06e01.mkv” and “Judge Judy s06e001.mkv” and probably a few others, all with the same issue.

Seasons of Judge Judy have over 100 episodes, and I’m not sure the correct way to format shows with more than two digits, or if there is a bug with shows with this many episodes. Either way, manually searching for the correct metadata failed to work

I created a test file using “Judge Judy S10E01.mkv” and while it didn’t automatically find the correct metadata upon doing an edit metadata it did find the correct one and offer it as a choice.

That being said, upon selecting it and it doing it’s little wait clock it didn’t populate the metadata so it appears that Judge Judy is yet another victim of thetvdb revamp.

Yeah, I get that far, but once I select “Judge Judy”, it fails to actually download and apply the metadata.

And I’ve confirmed that the metadata does exist on thetvdb, as linked to in the original post

Let me hammer on it a bit and hopefully we can figure out her honor.

Thanks! Let me know if there’s anything I should try. I’m pretty much out of ideas, though - this is the first actual issue I’ve encountered with Infuse in all the time I’ve used it

No change in the latest update, sadly. Also tested on the iOS version of the app, and I get the same results

We’ll take a look at this.

Thanks for the report.

Awesome, thanks! Let me know if there’s anything else I can do to help

Quick update.

This is related to an issue at TheTVDB, and something they are working to resolve. Fix should be out soon.

That’s great to hear, thanks!

I tested this again with the latest version of Infuse, still no luck.

Now, when I search for Judge Judy’s metadata using the app, it displays two results. One of them has a year, one of them does not. Neither actually work.

According to their forum the fix is in QA and hopefully be put in place soon.

The fix for this was released by recently. All should be working fine now.

I just tested on my Apple TV, and no improvement noticed, same problem as before. Oddly enough, when I search for metadata on the Apple TV, there’s now a second entry for Judge Judy, this one missing the year.

Still no improvement in the latest version of Infuse…

When you do a metadata search did you try selecting the new one without the year? Did you try selecting the one with the year? Infuse won’t update just because the correct metadata is in the list of possibilities, you need to select it and let Infuse re-fetch the new metadata.

Yes, several times. Selecting either causes the spinner to pop up for 10-15 seconds, then it exits the screen, with no metadata being applied.

If I select something else from the metadata list, feeding it intentionally wrong metadata, it updates quickly with that metadata, so there’s nothing wrong with the files.

Then it must still be an issue at thetvdb since Infuse will load a different (albeit incorrect) metadata but not the correct one. I’m not where I can test a few things but it may be a new issue for this show.