TV - Infuse Pro Subscription Error

Hello everyone,

I have an issue with my Infuse Pro :
I’m subscribed since October and today when launching an MKV, it put me back at the Subscription Selection.
I tried the Restore button, without Success.

I tried to click on Annual again, and it said I was already subscribed and right after: Network error (my internet works just fine)

Thank you for helping !

Did you try restarting the ATV?

Yes i did !
I even shut down my TV for 1min.

I have the same problem with Infuse Pro on my iPhone :frowning:

Did you by any chance change App stores or countries?

Any changes with your Apple ID? Family sharing?

Also there’s an older thread where another user had problems similar to yours. Check out this post in particular.

I did not change my App Store location or change my family sharing :frowning:

I’ll try your solution and come back to say if it did work!

I tried your solution and sadly it didn’t work :frowning:

It seems like the thread you’re mentioning does not have a working solution: despite the steps you’re providing I’m unable to access the pro version I paid.

Does anyone have another solution?

Sometimes the App Store doesn’t feel well and issues like this can appear.

Please try the following to resolve this.

  1. Tap the Restore button on the purchase prompt that appears.
  2. Restart your device, and then tap Restore in the purchase prompt if it appears.

If neither of those help, you may try the following steps.

  1. Remove the currently installed Infuse app from your device.
  2. Sign out of the App Store through Settings > iTunes and App Store.
  3. Restart your device.
  4. Sign in to the App Store through Settings > iTunes and App Store.
  5. If using a subscription, ensure this appears as active in Settings > iTunes and App Store > Apple ID > Subscriptions.
  6. Re-download Infuse from the App Store, and your Pro features should automatically be restored.

Hello James!
Thanks for responding!

I tried what you wrote and sadly I’m still stuck with a restore button that shakes and does nothing :frowning:

Do you have another solution ?
Thank you !

Are you switching between App Store regions or Apple IDs?

Are you using multiple Apple IDs on the Apple TV?

I have two accounts on my tv (my wife’s and I)
But we have only one AppStore (France)

I have the same issue on my iPhone (with only one App Store)

I really don’t know what to do :frowning:

Make sure that the account that purchased the Infuse subscription is default user on the Apple TV. It can’t be one of the added users since only the default users account has the iCloud connection.

Sadly none of the solutions provided worked for me, I’m still stuck with a shaking restore button

I’m the main user on my tv, I’m the only user on my phone and it doesn’t work either.

What do I do ?

Hello to the forum, I am also facing the same exact issue in different machines.

Apple TV under ios 15.3 and beta 1 of ios 15.4
iPhone 12 Pro Max under ios 15.3
iPad 12.9 M1 under ios 15.3

Single account on App Store, already done what James has suggested, unfortunately no luck

When trying to restore on all devices button shakes and I get an error that the network is not available. “Network Error Check your internet connection and try again”

Have already echanged several emails with support of Firecore but no luck.

1 Like

Please, any help would be welcomed :frowning:

1 Like

One thing that did the trick for me:

I just rebought the subscription… on my iPhone.
A quite expansive « restore » button glitch :confused:

Are you sure you’re using the same Apple ID on all devices?

It shouldn’t actually be possible to subscribe to the same thing twice using the same Apple ID.

I would wait and see if you get a receipt from Apple (this may take 3-4 days). If it does come through, check to see if the email address listed on that receipt matches the email from your original receipt.


Thanks James!
Can’t wait to know how this story will end ! :slight_smile:

1 Like

Hello je le même problème avec tout les compte famille
Impossible de restaurer l’achat de infuse pro sur tout les produit Apple
J’aimerai bien une solution
Merci et à très vite