Tv displays "No Signal"

Lets start by giving you guys the background.

I bought a aTV2 of ebay that was supposed to be jailbreakable. I did not have a tv at the time so i just plugged it to my computer and ran seas0npass downloading 5.0.2 (didnt want to wait for my tv in case apple would stop signing) and all seemed to work fine but today when i tried to hook it up to my tv it just displays no signal (no apple logo during boot or such, just no signal). The box flashes as in booting up and then stops at a constant led light. Seems normal to me.

What i have connected to the box is just power and hdmi, the box has never been connected to a ethernet cable nor a wifi (obviously since i cant enter the menu)

The tv and hdmi cable works with my computer.

I have tried a menu+down reset

I would like to try different cables/TVs but i dont have access to that at the time.

 

  1. Does the aTV2 require a special hdmi-type cable? I just bought a cheap one of ebay that said aTV.

  2. Does anyone have a solution for this problem? 

  3. Is plausible that my hdmi connection on the aTV is broken? 

 

Thanks

I think you need to Re-Jailbreak…That’s all. Good luck.

I donwloaded seas0npass again, re-jailbroke and found another tv, this time a samsung but still i gett “weak or no signal”. Atleast this tv recognises that somethins is connected to hdmi since the hdmi option gets enabled when i connect the aTV but still “weak or no signal”

 

Do you guys think its my cable or my aTV that is broken?

 

thanks

I just tried to restore to 5.0.2 (not jailbroken firmware) and still same problem.

 

Still, does the aTV2 require a special hdmi cable?

 

If i upgrade to latest firmware will i be able to downgrade and jailbreak using my shsh-blobb and tinyumbrella-“fakeserver”?

As long as you have the SHSH blobs for the firmware you’re trying to restore then yes you can downgrade.

Well i guess this device is broken, i tried the same tv,hdmi,powercord with another aTV2 and it works.

I tried upgrading to the latest firmware, downgrading, jailbreaking all i could think of but no luck. Does anyone have any suggestions on what to do?

So the device was broken, a new logic board fixed the problem.

Can you share where you got the new logic board and who fixed it?

 

They guys who sold the unit was kind enough to supply me with a new board and i then swapped it on my own.

 

Thanks for the quick reply. I guess I will have to find a source for a new board. Did he happen to mention where he got it or what the part number was

 

No he did not, i guess he disassembled another atv to get the part cause it came with the powerconverter still attached. 

 

Thanks for your info