Hi, I posted about this problem under a diferent title earlier, but I now know that the file transfer is not the issue.
I have signed up with a VPN service that supports openVPN, I have downloaded my five files from them including the vpn.ovpn file. I have renamed the file to vpn.conf and coped all five files to the ~library/openvpn folder on my ATV using cyberduck. When I then try and use the tunnelblick option(push the right arrow)in the maintenance menu nothing happens. if I then look in the file system of the ATV the files have moved to the resources folder in tunnelbrick.app in the applications folder.
Please Please help, :!: I have wasted an entire day trying to get this to work, I have searched this forum and elsewhere on the net and found lots of other people experiancing the same issue but I have found no fix.

cheers steve

Sorry, looks like there was a small bug in 4.1 that was affecting VPN connections that require a username/password. This has been fixed and is available in a Maintenance update through the Maintenance → Manage Plugins menu.

Once updated the username/password feature will work as expected.

Sorry for the trouble.

Hello again, I have tried the following, with no luck:-

1 reset ATV
2 updated ATV
3 Flashed ATV with ATVflash via USB
4 run the smart installer
5 updated “maintainence” app
6 installed Tunnelblick
7 transfered my 5 configuration files ( including the .conf file) via SFTP using cyberducky int ~library/openvpn
8 pushed right on the tunnelblick option and entered my VPN user/password

I can now enable tunnelblick but if I exit the menu and re-enter it reverts to disable, I have tried checking my IP location via the web browser but it says I am where I am!

I have checked the console (via NitoTV) and the final comment it makes is “cannot allocate TUN/TAP dev dynamically”

if it helps, here is my vpn.conf file:-

dev tap
proto tcp
remote uk.hideipvpn.com 443

resolv-retry infinite


ca ca.crt
cert clientpremium.crt
key clientpremium.key
tls-auth ta.key

ns-cert-type server



verb 3

Hopefully someone can help me, this configuration works fine on my mac and my wife’s macbook. The ATV is connected wirelessly to my Apple Airport extreme which is then connected to my Netgear DSL modem.

cheers guys

Was the AppleTV restarted after running the Smart Installer?

Hi, I can confirm that yes, my ATV was restarted after the smart installer did it’s thing. I have tried resetting the ATV and going through the proccess I listed in m y previous post three times now, still no joy

Which VPN provider are you using?

I’m using http://www.hipeipvpn.com, they offer a premium package which includes OpenVPN, this works great on my iMac 24inch and my wife’s macbook.
I have pasted the contents of my .conf file in a post above.


Hi, just a bit more info to maybe help you guys, I have just reset ATV again! after performing the smarti nstall, I held down “-” and “menu” for a while to properly power down/up my ATV, then did everything else as normal, sadly this made bugger all difference.
I have also tried connecting my ATV to my netgear DSL modem via an ethernet lead just to ensure there was no issue with my home network, again no dice. I still get the “cannot allocate TUN/TAP dev dynamically” error and the tunnelblick reverts to “disable”.

The frustrating part is that when you scour the net looking for people having the same issue, loads of others have had this problem but none of them ever gives details of how they fixed it.


I have an account with Witopia and I therefore was trying to use the Tunnelblick to get it working. I had some issues but eventually got it to work where it was enabled. However, in trying to open a browser page http://whatismyip.com it takes a long time and eventually shows me an error loading message. If I go back to settings and disable the Tunnelblick, then go back to a browser and test that same web page it works. So, I believe the connection is setup correctly, but for some reason it blocks all traffic while connected.

This may be a similar problem?

Anybody have any thoughts?