Trouble with Apple TV2 4.4.4 loosing functionality

Greetings,

I am trying to trouble shoot an Apple TV2 stuck in version 4.4.4. It was hacked with Firecore’s aTVblack a few years back.

I never bothered to upgrade it but ever since upgrading to Mavericks on the computer this Apple TV has been operating with less functionality. I did try upgrading the hack but it did not take becasue the the unit is not seen by iTunes (even after following all teh advice I could find online)

What it CAN do:

  1. Connect sucessfully to the TV via HDMI

  2. Playback media I have purchased through iTunes

  3. Airplay media from iTunes on any home shared computer

  4. Airplay media from iTunes on my iPhone and iPad.

 

What it will NOT do any longer:

  1. It will no longer connect to VIMEO within it’s software

  2. Airplay VIMEO and many other sites from my iPhone and iPad

  3. Update the firmware or Apple software wirelesly (Get the message the the update is not available, try again later - for weeks now)

  4. Restore to factory settings wirelessly

  5. Connect to iTunes via a micro USB (tried different cables I know to work)

 

I understand that it needs to be able to restore and upgrade the firmware and software to be able to airplay VIMEO and other media from my iPhone and iPad but since it will not be recognised by iTunes nor will it restore wirelessly I am at a loss.

 

What I have done so far:

  1. Tried connectinig the AppleTV 2 with diferent micro USB cables

  2. Tried trick it into DFU (mode both methods)

  3. Looked at the Apple support website which recomends a proceedure for the Apple TV 1 and a previous version of iTunes and is not applicable to this situation.

  4. Tried all this with diferent macs, though all run the latest Mavericks and iTunes

My next step is to see if connecting ot the mac with the ethernet cable makes any difference.

If anyone has a suggestion I would greatly appreciate it.

Thank you