Trouble with Airplay

I'm having trouble getting Apple's Airplay technology to work completely on my first-generation aTV Flash-enabled Apple TV.  I am able to make it work with YouTube videos--a YouTube video on my iPhone can be transferred over to my big screen TV by touching the Airplay button that appears next to the Play button.  However, I can't get it to work with anything else.  No Airplay button appears for photos, songs in my iPod app, or even videos that I took with my iPhone.  The Airplay button only appears for YouTube videos in the YouTube app.

Here are my software versions, which I'm pretty sure are all up to date:

• Apple TV: 3.0.2

• iOS:  4.2.1

• aTV Flash: 4.2.1

Any suggestions on how to get Airplay to work for all the media on my iPhone?

I have the exact same problem too, but with my IPad with latest iOS version. Only YouTube works. I also tested with AirVideo app and AVPlayerHD app and it doesn’t work. However, iTunes in my computers see the ATV and can reproduce video on it, so the problem is not on RemoteHD but in the iPad apps instead.

I really don’t know what happened, the non working apps used to work fine at the beginning…

Which version of Remote HD do you have installed? The latest 4.3.1 version can be installed through the Maintenance --> Install Extras menu.

Same issue with me on my first generation AppleTV.  Only able to use AirPlay with YouTube videos.


Would like advise on why this is not working properly.

I'm curious, what else SHOULD work. I've purposely not updated RemoteHD, atV or anything else since I got it working about a month ago... (at that time only thing I tested was YouTube) and they were saying that audio wasn't available.

apple must have changed some option in iOS 4.3.1 - my ipad2 is on iOS 4.3 and it recognizes the appletv and playback is ppssible through all programs which offer the option (eg eyetv)

but my iphone4 jailbroken w. 4.3.1 installed does not offer any airplay at all, it simply ignores the device.

any idea - remote hd has maybe to be fixed, have thenewest version installed