Trouble Upgrading to ATV Flash 3.5.4

Not sure if anyone else is running into problems installing the latest version of ATV Flash (3.5.4) but here are a couple of issues I ran into during the upgrade:

  1. As mentioned in other posts, it took multiple attempts to get the ATV Flash application to download a full copy of the ATV software. On multiple times it would stop downloading at various points and after hours would not complete the download. Also, we all know the progress bar percent if off. They have indicated that they are working on fixing that issue. No mater what, after a couple of tries, it did download a full copy of the ATV software version 2.3.1 and create the patch sitck. If you already have the version you want to use on your computer (there are other sites that you can download them from (i.e. ATV 2.0, 2.2, 2.3 or 2.3.1), you can skip the download and select the location on your hard drive (when asked), or just mount the ATV software prior to starting the ATV Flash app (should mount as OSBOOT).
  2. Not sure if anyone else has had this problem, but the only way I could get the ATV Flash to create a patch stick was to STILL RUN IT FROM THE DMG FILE (not copy it to the application folder). I know that previous version of ATV Flash required that, but since this new version indicated to copy the app over to your application folder during the install, I figured that was no longer required. Maybe it works on some computer, but not on mine. So, if you have tried to do the patch on your ATV and it doesn’t work (i.e., after reboot, the apple logo appears and start normally), try running the ATV Flash from the DMG file and see if that works.

Hope this helps someone
Mark