Trouble Mount a Shared Network Volume.

Hello everyone,

First off, I would like to say that I am new to the ATV Flash world and I am very excited about what everyone is doing here. It appears to be a great company and community and I am grateful that I stumbled across it. Please excuse me for my lack of knowledge here, I just purchased my first AppleTV this week and am new to it.

The installation and Smart Installer work great. I have even been able to transfer over some files to the AppleTV itself. My issue arrived when trying to mount a Shared Network Volume through NitoTV in order to stream some Movies/TV Shows from my Mac. I filled out all of the information and the following message keeps coming up:

Can anyone possible shed some light on to why I am experiencing this issue? The information that I entered when trying to mount the volume is as follows:

Mount Name: Travis’ Video
Mount Type: smb
Mount Address: 192.168.0.198 or macpro.local (both seem to be valid)
Requires Authentication: No
User Login: travisnabe
Password: abc123 (not the real password, but do not figure I need to post it here due to Authentication being turned off…)
Volume Path: Video (my shared folders are set up on my Mac Pro and I have followed all of the steps as outlined on the wiki… The precise location of the folder as represented on my tower is as follows: /Volumes/Hard Drive/Video)
Auto Mount: Yes
Use Custom Path: No
Custom Path: n/a

Thank you in advance to anyone who can assist me with this issue. I really appreciate any help that I can get to help remedy this and help me unlock the potential of my new AppleTV.

Best Regards,
Travis.

Any sugguestions? I would really appreciate any help from anyone…

Hey Travis,

You’ve hit an issue that many of us are having - that smb mount error comes up for me whatever settings I try - the strange thing is that Boxee works fine (mounting the same volume with the same settings) as does smb mounting directly from the Mac’s on my LAN.

Anyone solve this? I mean without bieng able to stream from a shared network folder I dont see much point for ATV for me at least.

Requires Authentication: No - must be YES

It doesn’t work for me either.
Maybe the administrators could look into this ?

The wiki pages are wrong - I did everything as stated there and the friggin’ thing doesn’t work ! :evil:

Seems like I wasted my money on this

I too am having mount issues.
What’s not making sense is that at some point, the drive shows up. About an hour or so after trying to mount it in the first place.
It doesn’t always show up mind you, so at times.

Will be contacting support by phone, as this feature, and the so called support, are the reason I purchased this “software”.

I’m having the same problem. Yesterday after a while worked fine, but then today, I get the “Network mount failed” message. I reinstalled Nito, I erased my previous mounts, I created them again, but the error keeps appearing.

Boxee and XBMC works fine with my Buffalo Linkstation, but Nito doesn’t.

As ottanon says, without being able to stream from a shared network folder, I don’t see much point for ATVFlash for me.

ATVFlash support team, please help us!

You may have an issue with your share point settings. If you post them here, or email them we can look them over.

I’m having the same problem too. Worked fine a few days ago. :frowning:

I’m also having trouble with mounting a drive via SMB - although I just get a failed to mount and I then having to hold ‘pause/play’ on the remote to restart Apple TV (which makes it a slow process trying fixes).

I’ve tried most of the suggestions I’ve come across on the forum and none seem to work (I’ve also experimented with trying to set up access via AFP but I’ve not managed to get this working either).

I’ve tried a factory restore and have the latest version of Nito, Apple TV and aTV Flash installed.

I can get access to my Time Capsule (connected via Ethernet) fine from XBMC so no issues with connectivity in theory - the problem appears to be occurring exclusively in Nito.

This is a real issue for me as the main feature I was looking for from this software was being able to access my Time Capsule without using XBMC / Boxee.

Any ideas on how to resolve this would be REALLY appreciated.

Thanks.

Hey guys… just upgraded my ATV from 2.4 to latest Software from Apple and aTVflashed it with latest one… no problems there… getting afp working was a bit more manual therapy that written in the wiki… but all ok also there now… but… seem to have the same problem and almost identical screenresult trying to connect to my MBP as on the screenshot in the beginning of this post… tried all possible combinations and settings… also checked and double-checked on the flash wiki… is there someone who can explain the procedure or what else to do if we get that result??? Hate to keep transferring files to ATV if I can just stream them to it - have my MBP on anyway all evening … (( Pliiiz oh wise ones?? )) Help and guidance needed badly!!!

The problem I had turned out to be a duplicate name of Movies . iTunes seems to have added that as a Shared folder as well. I removed the iTunes Movie folder and re-added the Shared Network Volume and all is well now. :smiley:

Sounds good… could you just run that one more time? )) Where did you remove the folder? You mean you unchecked it in Preferences Shared in iTunes? But in my case, I was trying to add Downloads as shared folder… as I just download movies there and usually after some seeding just delete them… and that folder is in no way taking part in all the sharing elsewhere… (( so I presume that solution doesnt help my case…

I removed it from the Shared Folders:

that did not change anything for me sadly so… (( any other ideas or suggestions…? anyone?

If you are getting a ‘permission denied’ error like the OP, you will want to double-check your username/password entered for the share point on the AppleTV.

No… the beginning of the message is same as OP… end part was differing… I have the feeling that I might be putting info in the Volume path wrongly… So whats the correct way to enter the paths… i.e. if I want to log onto my MBP’s Movies folder… I put Movies in “Volume path”… and leave “Use custom path” to off? (( Gives me:

Network mount failed!
mount_smbfs(568) malloc:vm_allocate
(size=3221221376) failed (error code=3)
mount_smbfs(563) malloc:
error: can’t
allocate region
mount_smbfs(563) malloc:*** set a breakpoint
in szone_error to debug
mount_smbfs: mount error: /mnt/Scratch/
Volumes/Movies: syserr=Resource busy

…and … the only thing different…just keep clicking the manually created sharpoint, the figure (568) in this example above just keeps changing on 571 … 572…etc… thats the number of times I have tried to mount I suppose or smth))) unsuccessfully…
…when I leave the Volume path empty… I get :

mount_smbfs(568) malloc:vm_allocate
(size=3221221376) failed (error code=3)
mount_smbfs(563) malloc:
error: can’t
allocate region
mount_smbfs(563) malloc:*** set a breakpoint
in szone_error to debug
mount_smbfs: UNC no resp dict, rd=0x0
mount_smbfs: UNC selection out of bounds 2>
2

advise please !

Ok your settings may be ok. A resource busy error would indicate the drive/folder is in use by another application. You may try restarting both devices and see if the issue persists.

Not sure if that was it, I mean restarting it… but… it works now!! )) yippi ) only thing I did check and confirm for 100%, the folder you want to mount NEEDS to be shared in Sharing settings of your computer… or an attempt to mount it will just give you another error about not finding it… and the reason why I was having btw the Resource busy error… it seems that I was just pushing the button too hard ))) I mean double… the folder was already mounted, it just happens too quick…sitting there in Files…mounted… waiting… )) as of course, the second push will not tell you that you ALREADY PUSHED THE BUTTON YOU SILLY…(actually that would be fun), but a Resource busy error message :slight_smile: so… all good here… and thanks for help ;):wink: