Trouble jailbreaking AppleTV 2 (5.3)-- iTunes error 1600

Hello all–

I have been trying to successfully jailbreak my ATV2 running 5.3 for several days. I am not an experienced JBer, but I have been learning a lot on the way.

I have the most current SeasonPass for tethered jailbreak of 5.3 … When I go to create the IPSW it requires that I plug in the micro-USB (although most instructions on the web say not to plug it in until after the IPSW creation step). When I plug in the USB all goes without hitch until I get to the iTunes restore part, where it says “error 1600”. The SeasonPass application says that all was created successfully, but the iTunes gives me the error 1600 and my ATV2 keeps the fast blinking light going on me. I tried Tethered Boot just to see if things were jailbroken correctly, but when I plug in the HDMI my TV says “no signal” and the light continues quickly blinking on the ATV2.

Any help would be GREATLY appreciated! It has been a long struggle trying to get this thing going!

 

cf2007

Also, when I go into iTunes in an effort to restore it back to factory settings and start from the beginning, it says “apple tv could not be restored. this device isn’t eligible for the requested build.”

 

Just to make sure, is your mode number A1378 on the bottom of the Apple TV?

Yes it is, moaner70.

I highly recommend using Seas0nPass on a PC and not a MAC - worked instantly for me. See here > http://forum.firecore.com/topic/10898

Seas0npass appears to have a fault on Mac OS X.

I had the same 1600 error codes when trying on a mac.

Having exactly the same trouble with seasons pess,it seems to download ok then goes on to restore in itunes which it does but does completley back to original apTv settings .I must have tried this about 20 times at least,really fed up if anyone can throw any light upon this problem i will love them for ever .Oh this is using Mac 10.7.1