Tried it all (seas0nPass, iReb 4): cannot jailbreak (1601 error)

I’ve now tried about 20 times to jailbreak my atv2. The first time I followed the instructions for using Seas0nPass on my mac running Snow Leopard. When it got time to restore in iTunes, the script reported a failure and pointed me to the SP firmware. So I tried to restore that in iTunes by 1) putting atv2 into DFU mode (no problem) and option-clicking to get the patched firmware. That failed with error 1600.

I tried this any number of times to no avail.

Then I tried the same process in Windows 7 (running under VMWare). Again, no problem getting into DFU mode, restoring the software results in a 1601 error this time.

Then I tried using iReb RC 4 to put the atv2 into DFU mode. It did that no problem and installed limera1n. I quit it and started iTunes but the atv2 never shows up in the left-hand column as it should according to several instructions available here and elsewhere. So I can’t restore the firmware using iTunes. If I put it back into DFU mode and try to restore in iTunes, I get the 1601 error again.

I’m pretty much at the end of my tether(ed jailbreak).

 

Help!

Just to answer my own post: the problem was the micro-USB cable. I realised I had another micro-USB cable lying around (the one that came with my Amazon Kindle), so I tried that and it jailbroke no problem.

So if you’re having 16xx errors and have a Kindle, try the cable for that and you might have more luck.

I’m getting the 1601 when trying to restore in iTunes on my MacBook (2006), but on my mac pro it runs fine. Same software, same usb cable. Could be the port on the laptop… though 4.3 version runs fine on my macbook.