Tried everything...still no DVD(Video_TS) playback

I’ve recently converted from Windows Media Centre to Apple TV and ATVFlash to play my DVDs in the Video_TS format but can’t get it to work after two weeks of trying.

Everything is up-to-date, i.e. ATV 3.0.1 and ATVFlash v4.0.6.

I’ve thoroughly searched the forum and tried several apparent solutions but still no playback. Under NitoTv->Files I can see the folder - named as the movie title with Video_TS folder inside - clicking on that I see “Play Title” but nothing ever happens when selected. It works in xbmc so I assume there’s nothing wrong with the rip.

I’d like to connect an external HDD to store the movies and have no preference whether iTunes syncs internally or externally.

Are there any other setup thoughts out there? This will be a huge waste if I can’t get DVDs to play so I’m listening to any suggestions.


Has the Smart Installer been ran? This will greatly improve DVD playback.

Yes, I’ve run the installer, restarted the ATV and still nothing. I’ve changed the Playback mode to Quicktime, again nothing.

As I write this, I thought about the format of a DVD rip and did some additional research which proved fruitful. Part of the DVD spec calls for an AUDIO_TS folder in addition to the VIDEO_TS folder. I simply added an empty AUDIO_TS folder and tried to view again in NitoTV. The movie started immediately.

Strange solution but I hope others can benefit. As a note, I used DVD Decrypter on a PC to do the rip so maybe the issue started here as it doesn’t seem to automatically add the AUDIO_TS folder. Maybe other software does it straight away and hence no issues for others.

Hmmm. Good to know.

I use OSX Snow Leopard and MacTheRipper, which always creates the AUDIO_TS folder alongside the VIDEO_TS one, and have no problems playing DVD’s ripped to an External Volume on this MacBook Pro mounted via Samba. The only annoyance is that once you’ve selected a DVD there’s no way back …

Same battle here…I’m new to the Apple TV / AtvFlash arena but so far I like what I see… I’m just wandering the learning curve a bit… I used DVD decrypter to backup my DVD but neglected to load the rest of the files from the disc… Didn’t play very well ( at all )on the Apple TV until I uploaded the remaining files… Some day I’ll sort out which ones are needed and which aren’t.

Currently, I find that even though the wide screen movie begins to play when I click on the folder in NitoTV, it usually crashes the Apple TV 5-10 minutes in. Rather annoying… I’ve updated the mplayer codecs, re-run Smart installer, and then done the hard reboot… It still does it… Any ideas??

What version of AppleTV software are you running?

Since the Apple TV was right out of the box, I updated to 3.0.2 just prior to installing Atvflash.

After fiddling with it last night, I can get the movie to run by skipping over the first portion of the intro… Oddly the file plays fine through the trailers, then I get a reset pretty consistently at about 2 minutes into the actual movie. If I skip over that section, the entire movie runs fine… I’m ripping another DVD now to test if there was a hiccup during processing.

The only odd thing is the Apple TV does not respond to the remote ( either Iphone or the stock remote that came with it ) until the movie ends… Normal??

A bit strange, but what you are describing sounds like it may be an issue with a part of the movie. Let us know if the issue persists after ripping a second movie.

So far, it looks like the movie has the hiccup. All of the DVDs I’ve ripped so far appear to work fine…

I’m still curious as to why the Apple TV doesn’t respond to any remote during playback but will experiment with that shortly.

Have you ever considered just plugging in a USB DVD reader to the AppleTV, and playing your DVDs with XBMC?

I did that, and it works. My DVD-RW is of the Samsung brand.