Trick to get Apple TV 2 into DFU mode

I experienced lots of trouble getting the apple TV 2 into DFU mode both during jailbreak and tether boot.

The only saving grace was the following site which suggested that you may also benefit from getting the device into DFU by first holding the Menu + Down arrow for a few seconds (until rapid blinking starts) and then holding the Menu + Play buttons for 7 seconds.

This is the only solution that works for me on my system.


Hope it helps you.

Thanks for posting this Roland.  Unfortunately, even this did not work for me, and I still can not get mine into DFU.  If anybody has other tricks to do this, let me know.


Thanks for posting this Roland.  Unfortunately, even this did not work for me, and I still can not get mine into DFU.  If anybody has other tricks to do this, let me know.



What worked for me was after jailbreaking I then did the tethered boot ( some say not removing usb helps but I did)

- press menu+down ( when usb connected)--> this reboots the atv

- remove the power ( this is what is not in most descriptions but it was the only way I could get things in DFU when performing the tethered boot)

- press menu+play for the 7 secs or so ( this will put it into dfu

- replace the power cable and continue


When finished do not disconnect the power cable. Just disconnect the usb cable and plug in the hdmi cable. You should then be at the selection of the language.

If this does not work for you please report back.





I could not get the aTV into DFU mode, but after using a different micro USB cable the problem was totaly solved.

Hi everyone. 

I am still having trouble getting ATV2 into DFU mode when Jailbreaking. I've downloaded the latest Seas0nPass  (0.6.7 (23)) and have an iMac running 10.6.6. I have followed the links above, and while have no problem with iTunes recognizing my ATV, can't seem to get past the Seas0nPass screen of Waiting for device to enter DFU mode....

Here are the steaps that I am following:

1. Do not have iTunes running


2. Do not have ATV connected to either power or USB

3. Run Seas0nPass and wait until it prompts you to Connect USB and then press and hold MENU and Plan/Pause for 7 seconds

4. Plug in ATV2 into USB and hold down MENU and Play/Pause for 7 seconds


I have ATV2 flash every 1/2 second, but nothing else - iTunes does not launch, Seas0nPass does not say anything about detecting my ATV2 in DFU mode. 

I have experimented with various permutations and when I have iTunes also launched (ignoring step 1) [this works if power cable is in or not in] at the same time as Seas0nPass, it does detect ATV2 in DFU mode. This is about as far as I have gotten. 


Do you have any suggestions? I have tried every combination I can think of (hold down Menu down once plugging in the USB cable, not hold down menu down, with power cable, without power cable, iTunes running, not running, micro USB cable 1, micro USB cable 2, iMac, MacBook Air).... nothing. 





I could not get it into DFU mode after about an hour of trying a tethered boot. The "downward arrow+menu" then "menu+play" worked for me so thanks!!

I previously JB and tethered book without issues but 2nd time around had issues.

Looking forward to an untethered boot as this can be very frustrating!!

A little trick I learned trying to get my Apple TV to go info DFU mode is to make sure both the USB and the power cable are both unplugged and then plug in the USB cable first and then the Power cable.  It should let you go into DFU mode.  

This still doesn't help my problem of no internet after I do a tethered reboot.



I had EXACTLY THE SAME EXPERIENCE. My original cable came via Amazon and a link I believe for the pwnage tool. I tried for weeks to get it to work and believed that it did since I was able to use TinyUmbrella to back up. But it did work with the DFU mode. I bought a new cable from RadioShack and it worked the first time and every time I have tried thereafter. The tethered boot works and the Firecore installation worked perfectly. 

Excellent, worked perfectly!

I came across this thread as I am having the same problem.  My atv doesn't even show up in itunes.  Is it meant to, even?  Finally had time to try and jb my new atv2 today, with greenpois0n. borrowed a micro cable, downloaded greenpois0n, and off we go, or so I thought!!! After 3 hours I still can't get it into dfu mode. I've tried every method on the internet. Tried on a mac and a pc. ATV doesn't even show up in itunes on the mac on the pc there is a usb error device, and an unknown device. I don't know if it is a problem with the lead or the device. Any ideas please?

In my experience if the ATV2 does not show up in iTunes then you have a problem with the micro USB cable and there is no point in wasting time to try and go any further until that is resolved. I had a total of 5 micro-USB cables availalbe to try, and only 2 off them work with ATV2. What the difference between them is I have no idea.

I found thes step to work like a charm.

Run seasonpass and create ipsw downloading the lastest patch and such. Even if you've ran the ipsw already.

once it is complete and itunes says it is safe to remove ur atv just click ok and leave itunes running.

go back to seasonpass and click the ok message which should bring you back to the main screen in seaonpass

with out closing any programs or unpluging or pluging anything into the atv (only the usb should be still connect to the atv and computer) run the boot tethered in seasonpass.

when prompt press and hold the menu and play/pause button for seven seconds.

this should put you into dfu mode

you can connect the power once seasonpass recognizes the device in dfu mode and you should tether boot sucessfully.

All I can say is that until you get the ATV to show up in iTunes there is no point in trying to start the Jailbreak process.

As to whether the issue is the cable (which is quite common) or something else I have no idea.

I have the same  experience as above to get it in DFU-mode. To know how long you should press the buttons, watch the blinking speed. i found this YouTube video , where the light-signaling is shown 3:54 out in the video. The video shows the pwnageTool, but the process of getting it in DFU mode works as described above.  

I also found this on the same theme with the describing the light signaling and two different approaches to enter DFU.

SeasOnPass responded immediately when it detected the AppleTV in the right DFU mode.

i am using seas0npass to get this work. 

1) Start off with your power cable attached

2) When iTune pop-up for installation, remove power cable

3) on tethered boot - put back power cable.

4) do this next to your TV.  after you are done, you don't want to take power cable out

Yep, it’s all about the power cable.
When I take the power cable OUT I see the ATV in the iTunes window. Then I put the power cord back in and run season pass. Also, after holding the two buttons down for a few seconds after you get the fast blinking, you LET GO and you get the DFU message.

Yes! It IS all about the power cable as mentioned above. Many many thanks!!! :slight_smile: :slight_smile:

Here’s what finally worked for me…

  1. The ATV should only have the mini USB cable attached, NO POWER CABLE

  2. Run Seas0nPass and let it do its thing

  3. When it asks you to put the ATV into DFU mode, PLUG IN THE POWER CABLE

  4. The light on the front of the ATV should start blinking

  5. Hold the menu and play/pause buttons together until the ATV light starts fluttering

  6. Release the two buttons and presto, Windows will load the DFU drivers and everything will proceed as it should.

Hope this helps. I went through the same agony of trying everything until this worked for me. Please give it a try.

MarkW: helpful, BUT most people need to then DISCONNECT the power cable as soon as the DFU mode starts working, or they will get a different error at the end.

My mistake was that I connected the appletv to a usb hub. When connecting it directly to the mac, the menu/play for 7 secs worked fine.