Transferring files taking too long? Unable to install Media Player? Reason and fix!

It is a server issue, it appears as though is taking a really long time to respond. That repo is likely shared with other iOS devices and a lot of people are installing the latest JB. To fix it, I did this;

  1. Run the installer, if it takes more then 15 mins close it.
  2. Run the installer again, it will finish very quickly, but also leave a few packages in a broken state (Media Player will say install failed when you try to install it).
  3. SSH into your AppleTV and run these three commands:

killall -9 apt-get aptitude
rm -f /var/lib/apt/lists/lock
apt-get -y update (if it times out or takes a really long time, press CTRL+C and run the command again)

  1. Reboot, install extras through Maintenance.

When you do the update from the command line you can see the progress for each repo, and for me took almost 20mins to complete since it was going at ~1k/s.

If you aren’t comfortable using SSH commands just wait a few days to update and it should sort itself out!

Don’t mean to double post this, but I figured having a thread with that title would be more visible.

When I try to run updates, I’m getting an error on the FireCore Packages…

HTTP Error Forbidden -

Any idea on this?

Is that during the first install, or when you try to add Extras?

If it’s when you add Extras (like Media Player) there’s a good chance your initial install didn’t complete, run the SSH commands I listed and reboot and try again.

If it’s during the first install, it’s probably fireCore’s servers being overloaded. Wait a few hours and try again.

I just found a fix on another list. Plug in a wired network connection and it runs in seconds

That worked for me!!

Thanks! You saved my night. I already quoted your solution in another post where people were having this same problem.

I had to try a couple of times because I received a timeout with the server. But finally made it.

Thanks again!


what the heck is SSH prompt and how do I do it? Just cause we jail broke our ATVs with Firecore, that does not mean we are all programmers. You need to include better instructions.

I’m not a programmer either, I don’t work for FireCore, and i don’t “need” to do anything for you. I assure you I don’t “NEED” to do anything for you the same way you don’t need to do anything for me.

I learnd what a SSH prompt is reading around multiple pages in this forum and in other sites. It plenty of it.

But anyway I tried to help explaining how I managed to solve this problem. If you want someone to “need” to do what you wan for you, maybe you can pay someone my friend.

If you paid for your aTVFlash black, demand a solution to them, this is a support forum, not a support service.

Thank you!

You don’t have to use this fix, the other option is to wait until the server’s aren’t as busy and just use the installer. The repo that is causing this problem is shared with other iOS devices and is being hammered from everyone trying to JB.

If you don’t want to learn about SSH just wait a day or two and the problem should go away.


I’ve never tried ssh before, but it’s easy (I’m using PuTTY).

Does it matter that “some files failed to download, they have been ignored, or old ones used instead.”

Everything seems to install and run ok.


Manners don’t cost anything matey- perhaps if you read back your post, and rephrase it, people might be more inclined to help you…


OK for all the people whining and crying about my post, here you go.

I build websites, and I have posted many instructions on different forums to help people. When I post instructions, I do not give them “partial” instructions and expect them to search the web for 3 hours to figure out the rest. That’s just rude. If you’re going to help or “support” somebody, you should do it with clear, FULL instructions, otherwise you’re not really helping. Now stopping crying like a bunch of little girls cause your feelings got hurt. :( I didn’t even say anything mean.  :slight_smile:

And for anybody ELSE that is having issues and doesn’t have 3 hours of extra time to search the web and figure out how to SSH prompt an ATV, this is what I did to fix it: I unplugged the ATV, plugged it back in and re-installed Firecore. I had to do this about 4 times before it would finally install Media Player, but eventually it worked. Maybe that will help, maybe not, but that’s what worked for me.  :wink:

mate, i could’nt care less if you throw your teddies out the cot- your post was in a tone that just would get people’s back up. I’ve used SSH on firewalls in work, but not familiar with accessing on an ATV2, so i just looked and found it on here…

take a chill pill and enjoy the nice weather ( if you’re in the UK :wink: )


jonez: This post is awesome. After following your instructions I now have Media Player and XBMC installed and working perfectly.


Wow. Where to begin.

For someone who can “build websites”, and has the time to post in several of the threads about this complaining about my steps, I’m a little surprised you didn’t think to do this:, search for “how to ssh into an apple tv 2”

First hit, Windows steps, third hit, a Youtube video tutorial on how to do it, fourth hit, Mac steps. You spent 3 hours and didn’t even try that?

Both Mac and Windows users use this software. Did you honestly expect me to post screenshots and step by step instructions for two OS’s so you don’t have to do a simple Google search? In case it wasn’t clear I’m not a fireCore employee, I’m just a user like you who found a fix and thought I’d post it.

Guess you missed that part. Or you didn’t bother to read it and just got mad you had to use your brain for 5s.

I had the same message but everything went ok and i was able to install MediaPlayer and XBMC.

Jonez… i was scared to try this but finally did and THANK YOU.

Ok, after waiting almost two days and still not being able to install mediaplayer i’m willing to give this fix a try.
Even though i think FireCore should maybe move it’ files to a server with a higher download capacity so that people who payed for the software can actually access it.

But the impatience is strong in me, so i’ m moving to the dark side…
never SSH’ed before, saw some video, but what is still unclear to me is this; how is AppleTV connected during the ssh process?
Should i use the micro Usb, or use the powerplug and do it wirelessly?
And then entering those three lines of code are all it takes?

Have been using fire core for a year now. Getting into the details with SSH is typical. Get used to it if you jailbreak. Am doing this on ATV2, ipad2,and iPhone4. All required history and knowledge about cydia servers getting overloaded. Jailbreak requiring the factory restore first before you can jailbreak. SHSH files getting saved, and ready to restore if needed. Blocking updates from apple.

There is a laundry list of tweaks and corrections that have to be followed way beyond what FIRECORE does with getting the jailbreak on your Apple TV.


     I   am having this problem from very long time but  Long Path Tool helped me in this situation. all u guys must try to fix this problem

I realize this is old, and maybe a dead topic, but I’m having a problem installing NitoTV and any other extras. When I try to install, it fails, and I get the following error:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.

I found this thread, and ran the commands. The killall command gives me a response of no matching processes found. Fine. I run the other two commands. While it’s scrolling all the updates, it stops with the same error:

E: dpkg was interrupted, you must manually run ‘dpkg --configure -a’ to correct the problem.


My question is: Is that a command that I run in SSH right now? Kinda new to linux/unix/ssh/what have you, and don’t want to brick my AppleTV.

Thanks for any help.