Trakt syncing not working

I have the latest versions (free) of Infuse on my iPhone 6 and IPad Air and on my atv2. I have set up the trakt account and have logged in on all devices. So now I expect it to keep up with what i have currently watched regardless of what device except it is not working. I am working my way through Game of Thrones and I’ll watch a few on my iPad, then when I got back to my atv, the watch count is where I left it before and not updated to where I got on my iPad. Any thoughts?

I will add that the website is keeping up with what I am watching so that is not the issue.

Are you running the new version (2.5) of Infuse for Apple TV?

Also, in order to pull down watches from other devices on your iPad you will need to upgrade to Pro.

Connecting Infuse with not possible atm…

I’m using Infouse 3 Pro - but i’m not able to connect from Infuse to - login not possible… moved up to tracktv2 - eventualy the problem?

Can you please fix this…

I have the same issue. (and am an Pro user) However, I am able to login to trakt from the infuse app.

The issue seems to be that infuse isn’t a connected app. When I login to the website and go to my setting and look for connected apps I see a couple, but not Infuse.

Might this be the problem?

before went to v2 the sync between infuse 3 pro and wasn’t a problem without beeing a “connected app”…
I think it must be a API faulure or something similar…

Other Apps like “iTV Show 3” didn’t got into trouble with the new API of

However, please firecore team - can you fix this?

… the only strange thing is: when looked at webpage there will be Infuse3 marked as API v2 ready… hmmm…

As of today iTV Shows 3 support version 2 of the trakt API. When I installed it it went over to trakt to explicitly ask for permission to be a connected app. To my knowledge Infuse (Pro) didn’t ask me this, so this might be the problem? In other words maybe Infuse simply doesn’t have the permission to sync with trakt via the version 2 API?

Is this only happening when attempting to sync between Infuse for iOS and the Apple TV? Are any issues present when syncing between iOS devices?

There is a bug we are tracking that is affecting users who have periods (EG ‘joe.smith’) in their user name. The API is currently preventing them from logging in, but we are working with trakt to resolve this.

Also, Infuse is using a higher level auth for trakt v2, and will not need to be approved before accessing your account. Once you’re in, you’re in.

Hi James,

nope my problem is the following:

I’m not able to login to account from within the infuse 3 pro app - got only a timeout error message…all since some weeks…
I tought its an problem with the API or something like that…

Hi James,

thank you for the prompt reply. Appreciate it!

I can login to trakt, but the sync between iOS and the aTV does not work.

I tried between iOS devices as well, but encountered the same problem (both Pro versions, both logged in).

I do not have a period (.) sign in my trakt login name.

Hope this helps.

P.S. I will retest between the iOS devices later today (hopefully within the hour) just to (re)confirm the issue.

=> retested the issue just now: trakt doesn’t sync progress between iOS devices. Bothe devices logged in, both scrobbling = on. My devices are iPad Air and iPhone 5.

Has this always been the case, or has it started recently? Is it happening with all files, or just a few?

I know there have been some trakt API issues over the past few weeks (more in the past week) but trakt is working fervently improve the stability of their API, so it’s likely it will start working much better soon.

Hi James,

trakt login from infuse3pro works actual like a charm…but my watched series in infuse won’t be synced to my trakt account…scrobbling is in infuse app activated…
Atm i’ve to mark episodes manualy in app like itv shows3 or similar…

Login doesn’t work for me.
Infuse 3 is NOT listed in connected apps in Trakt Website.

I´m from Germany, using Infuse 3 Pro.


Hi, I have the same problem from the beginning…
I have Infuse 3.1 with PRO In-app purchase…
I have three iOS Devices (iPhone 6 and iPad 3rd gen). On every device works login to trakt, Scrobbler is on.

So I don’t know how to use it or it doesn’t work (still I can see only the member name, number of movies and Scrobbler on/off switch, but I can’t do any more!
And when I’m playing something in my device, the counter of movies doesn’t increase, it doesn’t been add in my trakt account.

IT happens with every file I tried. Not sure when it happened. I had issues with watched episodes on a tv flash, but not on infuse on iOS. Now all devices have problems and are even out of sync with trakt.

Infuse 3 updated ( pro 3.2) still no connectivity to trakt…

I have the same problem…

We’re still looking into a few cases trakt login/sync issues, but it seems to be limited to usernames that contain a dot ‘.’.

We should have more news soon.

James, I can definitely confirm that it is not just usernames with a punctuation mark. I haven’t got it in mine and I have issues with syncing (logging in isn’t the issue for me)

no . (dots) in my email address
If it helps i can give you my email address and password i use @ trait