Trakt Not Working Properly With Plex

Hello all,

Just got Infuse pro lifetime and am loving it. However I am experiencing a weird problem. I have synced infuse with my trakt account but it will only show something playing when I am watching a TV show. It will not reflect on my trakt account when I am watching a movie. Any suggestions to remedy this?

I have log in and out already. Turned off and on cloud sync and have uninstalled and reinstalled infuse with no luck

I’m having the same issue on Infuse Pro 6.5.5.
Any luck? Thanks.

Perhaps if it cannot find the movie you are watching it won’t work. Another things is perhaps the trakt system is down. If you marked the movie as watched does it show up in trakt history?

I have this issue with every single movie.
Metadata is ok but won’t sync to trakt nor show up in trakt history.
TV shows work perfectly though.

Does marking something as manually watched, or submitting a rating in Infuse make it over to Trakt?

Do you have the Metadata Fetching optioned enabled in Infuse?

If info about ratings or items manually marked as watched isn’t making it from Infuse to Trakt, can you try this?

  1. Find a movie
  2. Open the details page, and select Edit Metadata from the 3 dots menu
  3. Select the correct movie title
  4. Re-attempt to rate it or mark as watched

I also have problems with trakt sync for weeks now.
Rating movies shows connection errors very often.
Movies I watched don’t appear in the trakt history.
Movies I currently watch don’t show the progress on trakt.

Everything is correct with the metadata.
Tv shows work perfectly, but movies won’t sync to trakt history.
Even rating a movie won’t show up.
I’ve tried logging out and back in to no chance. Uninstalling the app and setting everything up again, no chance.
Whether it’s on an iOS device or Apple TV.

Do you have metadata fetching enabled in Infuse > Settings > General?

Do all movies have fully matched metadata?

Can you try using the Edit option on of these movies, select the correct title from the list, and then see if Trakt works with that particular title (mark as watched, rate, etc…).

Sorry for the late reply. I’ve finally understood the issue. If the movie file is local, I’m able to sync progress to Trakt, but in this case, I’m streaming via Plex.
It works fine with tv shows streamed through Plex but not movies.
Could it be a Plex issue?

Which metadata agent are you using in Plex?

Have the movies been matched, or was metadata added manually?

If matched, you should see an unmatch option in Plex.

I’m using the Plex Movie agent not the legacy one.
Perhaps that’s the problem. Movies are marked as watched in Plex if I watch them in Infuse.

Edit: creating a movie library that uses the legacy agent works. I’m now able to sync movie progress to trakt.

1 Like


I have infuse pro connected to a Plex server and logged into trakt in infuse on all my devices with scrobbling activated. The things I watch however, are not showing up in trakt watched history. Am I doing something wrong, isn’t it supposed to work this way?


Do your titles in Plex have fetched metadata, or do they have manually assigned metadata?

Does marking something as watched in Infuse make it appear as watched in Trakt?

Hello, thanks for replying. Plex uses fetched metadata. And marking something watched doesn’t show up in in trakt no. I have tried just connecting to my server through FTP and let Infuse handle metadata and then trakt works without issues. Works fine this way, though I like to use Plex to handle my library and make sharing easy.

I have a similar problem.

I use Plex and trakt with infuse on my iPhone.

If i mark an episode as watched, nothing show up on trakt.

But if i download the same episode offline and mark it as watched there. It work and show up as watched on trakt.

It’s weird.

I have noticed Infuse fetches it’s own metadata for synced files. So I guess thats maybe why.

Well thanks, that was it.

I had “TMDB” as agent for my TV shows on Plex. I switch it to “TVDB” and now in Infuse everything sync fine with trakt.

I guess you must use in Plex the same agent that infuse use for it to properly sync with trakt

Cheers, got It working that way too :slight_smile:

Thanks for following up. We’re going to take a look into this.

1 Like

Anyone else having issues with Trakt not scrobbling playback info when playing from Plex, seems to pick up plays directly from Infuse library.