Tiny does not recognize ATV2???

I have a functioning ATV2 already JB but want to update the saved BLOBs.  On either a Mac or PC when I connect the ATV2, all Tiny shows is a series of ?XXXXXXXXX where the X’s are  numbers.  I remember before, it would say AppleTV.  I have tried with iTunes open and closed, power cord and no power cord.  What am I doing wrong?

Yeah it happens.I have faced the same issue. But in my case I just rebooted my computer and ran tiny umbrella first connected the microusb cable. And try to restart the TV and be sure that you have entered your details correctly.

A little old but you get the point: http://www.ijailbreak.com/how-to/learn-how-to-save-your-apple-tvs-shsh-blobs-required-if-jailbroken/

I also rebooted my computer and ran tiny umbrella first connected the microUSB cable. And then I just restart my TV and it perfectly works. But try to connect your Apple TV to your computer with your microUSB cable correctly. The connection problem also matters sometimes.

Still not working.  I have 4 ATV2 that I know I did the Tiny on 2 of them before using the same cable, etc.  Now all 4 of them come up with the numbers.  I have tried on both a PC and Mac.  On both, iTunes recognizes the unit so the cable has to be fine, but I have tried 3 different cables.  I have tried on clean boots of both with nothing running in background.  Tried with and without power cable.  Can anyone please help me as I need to save the blobs before something happens again and I have to JB.