Time Capsule NAS Infuse 2

does infuse 2 support SMB shares? I have a time capsule with a hard drive attached (usb) my Apple TV 2 infuse connects, errors almost everytime on the first connect but then it always see’s it the 2nd try. i’m using the same details for my iPad / iPhone (infuse 2) and they both see the hard drive but when you click to view the files it just error’s everytime! there is no way to tell the saved share it is SMB / AFP like on the Apple TV 2… could this be why my iOS devices are not connecting?

 

any ideas why my Apple TV 2 always errors the first time connecting?

 

Infuse 2 does look really good, great work firecore just gutted I can’t seem to get my share working!

 

Yes, Infuse 2 does support SMB. We have a detailed guide on setting up shares which can be found at the link below.

One thing you may want to check, is that when connecting to a Time Capsule or Airport Extreme the username must be set to ‘guest’.

James,

I know how to set the share up & my message does clearly state I have it working with infuse on my Apple TV 2. It fails / times out the first time on the Apple TV 2 but then works without fault the second time. I have tried connecting using the registered user name & guest both with the same result! I can see the disk but when you click on it you just get an error every time.
Please see photos attached…

I have almost the same problem, except I don’t get the errors. When I connect it just shows an empty folder. I have the same setup; connecting to external hdd on an Airport Extreme with SMB enabled just like the guide here shows. Using guest as username. It has always worked connecting this way with the Apple TV. I also tried connecting to my Macbook Pro that show up in the list of available connections but then I get an error. I have tried all available solutions on this forum and followed your step by step guide, nothing works… What have I missed?

Hmm ok. One more silly question that I’m sure isn’t the cause, but are you certain you are using the Disk Sharing password for the Airport Extreme and not the Wi-Fi password? These can sometimes be different.

Not silly but no I am 100% sure I have the correct password. Also I don’t think i would be able to see the disk’s if I had the wrong password?

Seems I’m not the only one with this problem? Sure there are other people using a time capsule or AirPort Extreme as their NAS… On the pictures from firecore you have your own time capsule is the USB hard drive working on yours?

Hello I have a similar problem I can connect to the time capsule Infuse didn’t show any error but no files on it (I tried with avi, mp4 and mkv). I put the files on time capsule I try to change the password too but I can`t see ani file on my ipad.

I have a similar situation.  I have an Iomega NAS with an external HD as additional storage connected to it through usb.  The iomega nas has a folder/share named “movies” and the addtional storage just has tv shows.  All files in the tv share are able to stream flawlessly and they are a mix of mp4 and mkv.   The movie share plays only a few of the hundreds i have tried.  The weird thing is if i move a movie that will not stream into the TV share it will stream no problem.  They are all in the same NAS with the same password, permissions etc so not sure what is the problem when the file is sitting in one but not the other. 

James have you had a chance to test this on your time capsule or AirPort Extreme? Sorry but I have been waiting for this for ages! I have spent a lot of time today trying different things but no luck infuse 2 just will not see my USB files.

Yes, we’ve tested this on a few Airport Extremes and haven’t run into any trouble.

A few things to double-check.

  • Enable file sharing option is enabled
  • Login details match what is setup on the Airport Extreme (or use username of guest if either With device password or With a disk password are selected)

[[wysiwyg_imageupload:439:]]

James I have gone over the details you are saying a number of times, also if I didn’t have it set up right then how come infuse on my Apple TV 2 is working? The share is correct, infuse 2 is just not working. I have a 1TB hard drive, in your tests do you only have a few films loaded? All I can say is it looks to time out…

James,

I have restored my time capsule to factory & gone through setting it all up. Great news infuse 2 is now seeing my shared disk, it does fail a few times before connecting maybe 2-3 times and then for no reason (not changing anything or doing anything different) it connects to the share & works perfectly. (error, seems like a time out to me)

Anyway maybe it’s a timeout bug & hopefully this will improve on 2.1… Thank you for your support. Keep up the great work! My shared disk is 1TB & only has around 20GB free so maybe this is info that may help.

Hmm, interesting. Were you running the latest AirPort software before the update? I know we tested with the most recent, but I’m not sure how far back (if any) versions we went.

There are some stability fixes coming in 2.1, but the SMB core itself is set to see an update after that…probably in 2.2.

Happy to hear you’re up and running though. :slight_smile:

It was up to date before I restored it, I could see the share but it just always seemed to time out…

All up & running so really looking forward to the updates, will downloading from NAS to device be a future add on do you think?

Yep. Downloading from network shares is in the works and will likely be available in 2.2. :slight_smile:

I have finally got the streaming to work from my MacbookPro! All it took was a reboot, don´t know why… The streaming is superb, works flawlessly! Thank you for a great update! But… what I really want to do is stream from my external drive connected to my Airport Extreme (latest model). I have still not got this to work… I can still see the Airport Extreme but when I try to connect to it (using “guest” as username and my device passport) I only get a blank page, no errors. I thought maybe it had something to do with my harddrive, but when I connected it to my Macbook it worked just as well as from the Macbook itself. Any further suggestions?

Having trouble too setting up Infuse 2. The setup works with my AppleTV2 with infuse for the AppleTV so it know it’s been set up correctly. But whatever I try on infuse for iOS, it will not show up any folders. It won’t even say it’s connected. Just a white empty screen. I even entered a wrong password on purpose to see what happens. Just the same. No error message just a white screen. I’m puzzled.

Found it! Instead of guest I had to type “gast” the Dutch word for guest. Strangest thing ever! I can use guest on the AppleTV. Weird!

Now I´ve tried both the dutch word for guest and the swedish. :slight_smile: Unfortunately this didnt´t work for me…

Try using Administrator as the user name. That did the trick for me.

 

It’s weird because I have an ATV2 with Flash Black and I can connect to my Airport Extreme’s attached USB drive using the guest user name but for Infuse 2 on my iPad I had to use Administrator as the user name. Go figure!