The icon and label of a favorite are blurred sometimes

Using:
Infuse 6.2
tvOS 13.0

I can’t reliably reproduce this bug, but sometimes the resolution of the text label and icon of one of the favorites is lower than usual. Here are some of my observations:

  • If you move the focus to the low-res favorite, so that its icon and label become larger, the graphics are correct. And once you move the focus away from the low-res favorite, for a split second after it has become small (or regular size), the graphics are correct, but then they become low-res again.
  • If you click on a low-res favorite to enter it, and then press Menu button to go back, then that favorite (that used to be the low-res one) is now correct, but one of the other favorites is low-res.
  • If you force quit Infuse, and then restart it, all icons are correct again.

I took two screenshots with different zoom levels in Apple TV Settings. In both of them the “Movies” favorite is the low-res one.

Hmm, that is pretty strange.

Can you try updating to tvOS 13.2 and see if this is still an issue?

I just updated tvOS to version 13.2, and I’ll post here if I still encounter this issue. But should I also go to Infuse > Settings > Submit Diagnostics if/when I see the issue again?

I tried doing different things earlier today (like creating a custom playlist and assigning artwork for it in different image formats, because I remembered doing something like that just before the first time I noticed this issue), but whatever I tried I couldn’t reproduce the issue. Then, some time later, I did nothing but wake up Apple TV from its sleep, and I saw the issue again (and all this happened before updating tvOS).

And on that latest time I noticed something I hadn’t before: one of the tv show (season) posters on the Infuse home screen (or whatever it’s called) was also displayed in lower resolution. I’ve always had Infuse > Library > TV Shows > Unwatched added to my lists, so that it is displayed on the home screen, and the low-res poster that I noticed was for a tv show that hadn’t been there before (I had just a little while earlier added it to my SMB shared folder, and again, I don’t know if this has anything to do with the issue).

Yes, if you see the issue again please submit a report via Settings. You can post the 5 digit code here, so there’s no need to send in a separate email.

Thanks!

At last I saw the issue again. Although this time it was a bit different in that almost everything was blurred. Here’s what I did (in chronological order) after I saw the issue:

  1. I disconnected the ethernet cable from Apple TV because I incorrectly thought that the device needs to be using Wi-Fi in order to take screenshots

  2. Due to the fact that my TV is 4K, and my Mac’s monitor is HD, I used tvOS Settings to zoom in to 2x, took four screenshots of Infuse using QuickTime Player on my Mac, and combined the images to create the attached file “infuse_6_screenshot_blurred.png”

  3. I submitted the diagnostics (while still on Wi-Fi) and got the reference code YJ9GH

  4. I quit Infuse via the tvOS app switcher and launched Infuse again

  5. I saw that the graphics looked correct again, and took another four screenshots and combined them to the attached file “infuse_6_screenshot_correct.png”

If you compare the two screenshots (preferably in an image editor that lets you layer the images on top of each other and then toggle the visibility of the top layer), you’ll see that everything is blurred/low-res in the first image except the large labels: “Favorites”, “Unwatched TV Shows”, and “Unwatched Movies”, plus the search box. But I believe that the search box was also blurred when it was not the currently selected element - as I’ve mentioned before, the element with the focus/selection/enlargement always looks correct even when it’s low-res when unselected.

EDIT: I just noticed that the magnifier glass in the search box is also blurred even though the search box is the currently selected element.

I’m currently seeing this issue again, and it’s manifested exactly like I described in my previous post - almost everything is blurred in the main screen (and by the way, everything is fine inside “folders” like Library, Movies, TV Shows, and custom playlists). But I want to correct the quoted statement in my previous post. The Search text in the upper left corner of the main screen is actually always sharp (i.e. correct), even when it’s not selected.

I’d also like to add that both this time and the previous time I noticed this issue, the Apple TV woke up in the tvOS home screen (the one with the app icons), and I navigated to Infuse via the multitasking app switcher thingy (like I always do, since I like to keep the current selection in the home screen on the Apple TV app, because that makes it easier to launch the screen saver manually by pressing home button followed by menu button), and initially the Infuse instance in the app switcher displayed only a picture of the Infuse logo with an orange background, unlike normally when it displays (a smaller version of) the current application view. Currently, now that I’m in the Infuse app, the application switcher shows a picture of the app view as expected.

Thanks for the info.

We’re currently looking into this.

I’m using Apple TV 4K and tvOS 13.4 (don’t know since when) and I’m seeing a brand new issue since yesterday. Although, I don’t know if it has anything to do with the previously reported issue, but I figured I’d mention it here due to some similarity. This new issue certainly cannot be due to Infuse, so it begs the question whether or not the reported issue is due to Infuse either.

The new issue is that the text in Control Center is blurred. It doesn’t matter whether you look at the Control Center while in Infuse, at the tvOS Home screen, or somewhere else. Control Center is what pops up from the right side of the screen when you long press the Home button on the Siri Remote. Putting Apple TV to sleep and waking it up doesn’t fix the issue, but restarting via tvOS Settings > System > Restart does fix it temporarily. But after a while the text in Control Center is blurred again.

I zoomed-in to 8x via tvOS settings on my 4K TV and took the following screenshots that show the difference between the “crisp” normal look of the Control Center and the “blurred” one. It’s easiest to compare them if you put corresponding images on different layers in an image editor and toggle the top layer. You’ll notice that only the text seems to be blurred.