The Black Screen Of Death

This issue has me pulling my hair out. It’s the same issue referenced here but with no real solution.

Installing ATV flash from scratch and successfully up to ATV 3.01 and Flash 4.02. Then changing from internal to external storage. All with no problem. After rebooting though I get the standard intro apple logo, flying pics etc…THEN instead of the menu I get a black screen. The ATV is obviously responsive to the remote because I can hear the beeps and clicks of scrolling through the menu…and that’s it…Just a black screen!!! There is no fix for this other than a factory reset which means the external storage has to be reformatted by ATV every time I reinstall…This basically renders the ATV useless if I opt for external storage. It does NOT recognize the drive again that was formatted in the previous install it just locks up when I try to change again to external (Luckily I have not lost any media over this problem). You can’t download an earlier version of Flash from Fire Core, it’s just not possible, so THAT avenue of trouble shooting is out - (to figure out if it is an issue in 4.02, or did it exist in earlier versions.) It’s not a plug-in issue that I can see because I only install the basic smart installer to activate the USB and little more. I’ve now had to reinstall 8 or 9 times. I don’t want to give up on this (though I may have to If I do another reinstall and the wife flings it out the window from the time I’m taking up the TV with this :shock: )

Any ideas on this guys??

P.S. On the upside and if anybody is interested, I’ve successfully attached a 12 TB Drobo Pro (with the option of upping that to 16 TB) on the USB connection. Am going with RAID 5 dual redundancy so with a full load of 16 TB I’d have storage of between 11 and 11.5 TB. [I could have 2 drives fail and still not lose any media]

I have the same thing.

Very disappointed as I only just bought the software including lifetime updates and had a few days of use before the update. Since the update I haven’t been able to get this to work.

More disappointing is I have received zero support. This is a paid product - not something that is free… The support needs to be spot on given I have handed over my hard earned dollars. Sent a support request 2 days ago and no reply. :twisted:

I look forward to the developers sorting this out soon and getting back on track.


Still not working. Got a reply to my support request asking what the external drive was and nothing since.

For the record it is a Astone case - 1TB WD drive. It worked for the week from when I purchased this software to when the update hit. Now I am running my ATV without the software.

I know support is a PITA but thats what I paid my money for.

I’d also like to roll back to the previous version but as mentioned by the OP that is not an option on the ATV Flash site.


Hello everybody,

I’ve got the same problem since today.

But at the begining of my problems, My AppleTV freezed during a sinc with itunes.(external HDD)
For me it was not a problem at all and like the other times I power off my AppleTV by unplugging it and normally by repugging it I find it in good state.

But this time, only the black screen came !!!
I don’t know what to do.

If I reboot the AppleTV the startup animation is visible, then blackscreen and the remote make noise in the menu (i think) and if I stay a moment, the screensaver by defaut (Apple pictures) appears.

Can somebody help !?!

(sorry for possibles misspelling i’m French and don’t use to write in english)

Well, I done the last possibility.

I have restored the factory settings.
And after a long time of upgrade and reinstall I found again an ATV in good state.

Got a message from support last week with some steps to try to get it to work.

Left it to today but I noticed there was an updated version. (At this rate the 99 download limit doesn’t seem enough! :smiley: )

[Bugfix] Maintenance (2.3) - Fixed minor USB primary storage + codec bugs

Seems to be OK - Syncing my library over…

HINT - Don’t use wireless to do the initial sync. Run ethernet and get it done in a fraction of the time…


Thanks for the hint by ethernet but since the last time i don’t have a new big crash with the black screen.

But, My ATV did other freeze/black screen and each time i did a reboot with the recovery application, the only available when my ATV bug.
And for the moment it works.

ts a ATV BUG you prob have 1.2.1 you need to upgrade it

installing ATVFiles-1.3.0b1.

You can either ssh ATVFiles-1.3.0b1 to Atv or run the following command from terminal


Once the .run file is on atv you can install from terminal

chmod +x


 returned error "Permission Denied" what next?


Last night I got the black screen,, unplugged the power from back (which is a real pain to do, it's so tight) got to initial glitz,, and then it goes directly to black screen. I went downstairs to check my iMac,, and the Apple Tv in my iTunes.  I checked to see how much room was left on ATV hard drive,, and I think there was about 1 1/2 gigs,, and that was all.. I unchecked a few movies to be synced (you still have access to them if your mac is on), created more space on the ATV,, and then Sync was able to operate. I think the black screen showing up is a glitch in the sync process showing up as a black screen. By the way, I hadn't used my ATV for a while, and is always running, while I am watching TV in another input mode. I think I must have hit the remote a couple of times by accident, thereby doing something to the ATV unknowingly, while I was watching my real TV. Hope this helps someone. Let me know, if anyone is helped by this.


I have a simlar thing (and same BSoD unfortuneatly!)

Like Suvamatt, I've gone through the cycle of install of ATVFlash [4.2.1 (924)] and factory reset (ATV v3.0.2) a couple of times.  And, once in BSoD mode, I can hear the audibles when I click the remote buttons, as if only the video is not displaying correctly.

But in my case, after installing ATVFlash everything works great, the menus, applications, everything... but only for a while.  While it's working (not in BSoD mode), i will have been navigating the menus or watching a new video, then, do something simple that I've done a hundred times, like stop the video, switch from XBMC to nito, or some other simple thing like that, when, BANG!  I get the following error message:

   "!An error has occured.  Press Play/Pause button to restart your ATV"

Once I do this after this error, I get the BSoD.

braddk: How do I check whether or not I have 1.2.1 (of what, btw?)

I'm not using any external disk for storage, so I've left the default to internal. Should I have switched this default to "external", and then, if I do this, do I have to attach an external disk?

I suspect it has something to do with the "nito Smart Installer" as I had nito/XBMC/Boxee all working stable (from another source) not using fireCore's ATVFlash, and that other "install" didn't have this partcular item. I'm going to try NOT installing the smart installer and get back to everyone.  But if someone has found a solution please, or if you need any more info from me, let me know.

BTW, I'm down to just the default install of ATVFlash, plus installing nito Smart Installer, XBMC and Boxee and can reproduce the error and the BSoD rather easily/repeatedly.

PS  Forgot to mentioin that I have the 1st generation ATV (not the black) -- dg

Think you have to do a factory reset.

Hold down the MENU button and hold down the "-" Down button at the sametime.  Unplug and replug the appleTV.  Supposedly you get a request to factory reset after that point.

I am paraphrasing the instructions horribly, but someone else did this and was able to get the Apple TV running again.


Thanks ktijeensen, but, if I wasn't clear, this is exactly what I'm doing everywhere I've said "reset".  That is, I do a factory reset, holding down the "menu" and the "-" button and unplugging as you're mentioning/suggesting, to get out of the BSoD state.

Again, my problem is not installing ATVFlash nor getting back to a factory reset state. My issue is once I've installed ATVFlash, and everything is working beautifully, after some (random) time, I get into a BSoD state after doing something innocent like, oh, hitting the "left" button to move from right-to-left in the menus, for example.

This will happen at different times doing different things, but if I stay "on" long enough I can make it happen (repeatable).

I have been using the Apple TV V1 for about a month now.  With ATV Flash.  have no issues, and no problems.  But I do not trust it to work. 

1)  Are you using HDMI cable, or are you using COMPONENT video cable?  Guessing that somehow your machine thinks it is COMPONENT and turns off the HDMI.

2)  Are you using the internal original disk drive?  Just wondering if the software is messed up on either internal or external drives.  Wild guess with this one.

3)  Did you do all upgrades and installation via a CAT5 Eithernet connected cable?  Not via WIFI?  have read of that being a suspected problem corrupting some software.

4)  Is your THUMB DRIVE fully functional and working.  Some have had corrupted software from a bad THUMB DRIVE.

5)  Have you run the NITO TV software update (not sure if this is the exact name - takes half hour to do on a fast internet connection, as it retrieves software updates)?  This is in the maintenance menu (I think - and might be quoting this wrong).  This seeems to update all the internal software and drivers on the Apple TV V1 all post ATVFlash.  Have read that some have needed to do this to get full functionality out of the Apple TV V1.

good luck.