The Apple TV "Apple TV" could not be restored. This device isn't eligible for the requested build.

 Apple TV has been jailbroken as per instructions. Attempting to restore using AppleTV2,1_4.1_8M89_Restore.ipsw, I receive the following error: The Apple TV "Apple TV" could not be restored. This device isn't eligible for the requested build. Where do we go from here?

the device can no longer be restored to that FW, apple stopped "signing" it. you must have you SHSH blobs saved thru TinyUmbrella. but.... it may be too late now. you may be stick in DFU mode, and are now forced to restore to the latest FW 4.2.1. sorry. :(

Yep. Got the same error message. If FireCore fixes the iOS 4.2 Jailbreak and the Apple notification thing I think we'll be closer.

it is not FireCore, at this point it is the Jailbreak Dev-Team need to update the jailbreak software to support 4.2.1. then all will be ok again.

pretty weak that it's not in the documentation though. It's not like the beta was launched and then the firmware upgrade. If most customers were prompted to upgrade firmware weeks ago firecore could have saved us much wasted time by putting this information at the top of the instructions. As this is my first experience with them I'm hoping that they do better, but I don't like killing an hour of my day to find out that my standard configuration isn't supported.

Unfortunately once you upgrade to AppleTV 4.1 (iOS 4.2.1) you cannot go back (unless of course you previously saved your SHSH blobs).

We're working to to have an updated beta that is compatible with the 4.1 software.

well this bites.  I was wise enough not to update the software, and I kept the previous firmware that was jailbroken including the original AppleTV3,1_4.1_8M89_Resotre.ipsw.  everything worked perfectly or so I though.  Since I had plex previously installed this beta broke plex.  I attemped to install and uninstall plex using the ATV black interface and it bricked my ATV.  Had to do a restore which also updated the unit.   It was good while it lasted.

 

As I've said you would save your users and yourself a LOT of time to have this information right at the very top of your documentation.

Just one question, which I asked as the second part of a two part on another segment but it didn't get answered: Will registered beta users get an email notification when the IOS4.2/ATV4.1 compatible version comes out? I'd certainly prefer that over checking.

Thanks, I know it's a mad rush to get everything out,

Ditto, "pretty weak." We'll just call this strike one, grin and bear it for now. Those of us on the cutting edge are bound to bleed once in a while.

Yep - we need to get a note added to the knowledge base pages.

Regarding updates, we will be sending out email announcing new beta versions - but if you get anxious you can always check here. :-)

Do we have timeframe yet as to when a fix might be out?

Tried with 4.0 and didn't work- apple doesn't support the software you link us to (AppleTV2,1_4.1_8M89_Restore.ipsw). When you say you are working to have an updated beta that is compatible with 4.1 software- do you mean 4.2? Cause you are linking to 4.1 off the bat, so should you be linking to 4.0 software? 

 

EDIT- nevermind- saw this

 It is a little confusing as there is some overlap in the version numbers. We're working to have a 4.1 compatible version of aTV Flash available soon.

For future reference:

ATV 4.0 = iOS 4.1

ATV 4.1 = iOS 4.2.1

I got the word to save my shshblobs at 4.1 and did it. I made the mistake of updating to 4.2 the other day cause I wanted to play with airplay. but the jailbreak for 4.2 should be coming soon.

 

cjaerw, agreed. Definitely would have saved us a heap of time and trouble had this been mentioned in the instructions. 

robertd.08354, I dig that! I'm going to steal it. "Those of us on the cutting edge are bound to bleed once in a while." 

James, thanks for letting us know. This was me yesterday…  =O

 

"OK, now cut the blue wire."

"They're all blue wires." 

"What?!"

"All the wires in this bomb are blue!"

"They're not supposed to all be blue!"

"I'm gonna put in my report that this was a VERY poorly designed bomb!"

 

[quote="php4me"]  

robertd.08354, I dig that! I'm going to steal it. "Those of us on the cutting edge are bound to bleed once in a while." 

[/quote]

this is a very true statement, you cant expect to be the first to get something, and it work everytime.

Sure would have liked to know all this before signing up for the beta, but oh well. I hope FireCore will send me an email when the correct firmware is avalable.

Thanks for these forums.

Henry

this is why its a beta, they are learning things too. i dont think FireCore knew this would be an issue. i dont think they realized that the new update for the aTV was not JBable.

".. As he said you would save your users and yourself a LOT of time to have this information right at the very top of your documentation..."

Not in the knowledge base pages! On the top of the page. The users read "atv patch for apple tv 2" klick to pay and then is to late!

This is unreliable.

what i don’t understand is that my apple tv says im on 4.0 but i still can’t jailbrake??

Damn, so after trying the restore for hours and iTunes kept telling me that "this device isn't eligible for the requested build" I searched and found this. :(

I woke at 5:30am just to work on this and install aTV Flash. I agree that they should specified that if your device is not jailborken or u didnt saved your shsh blobs YOU CAN'T jailbreak it now and you will be forced you upgrade your ATV2 to 4.1 (which is 4.2 not jailbreakable at the moment).