Thank You for Seas0nPass fireCore !

Have to state ... Thank You for giving us access to Seas0nPass, I really like the interface and the ease to apply

the jailbreak.

As I follow the forum, I see a lot of errors are due to not reading properly the instructions and crosschecking that people

really use the proper ispw and really enter DFU correctly. Or even being on the proper OS to apply the current version -

and - after last nights 0.6.4 issue, the updated version really dropped in quickly and I installed it just in a couple of


Keep the great work up !! Thanks again !!


My only left bug for the moment with Seas0nPass is the broken scripting - because I assume the modified IPSW is

saved to another location than expected with earlier version (I have it in the root - not in ~/User/Documents where iTunes

seems to look for and in ~/User/Documents/Tether is the original version).


Yes , I agree, nice work folks!

I tried to jailbreak my 4.1.1 and SeasOnPass worked fine, I jailbreake it, when iTunes openned I got an error so I manually selected the crested file, after it was restored I thetered boot my apple tv. After that I was abble to install flash (black) and I even saw nitotv option, but after turning it off and on, I got crashed on apple logo.

I tried again and again, same error.


What did I do wrong?


SeasOnPass is great and easy to use, but the instructions are not very clear to me.

I found that most of the time, the script would find the ipsw - it just took a few seconds.

When the finder window opens in iTunes - LEAVE IT for a little while and see if it works ?


I was having massive troubles restoring until i realised that i still had wifi sync installed. Removed that and it did it first time.

If your apple TV just gives you a black screen after tehered boot, just try running the aTV installer again while the screen is blank, this did it for me!

Success with two new aTV2's. Followed instructions and SeasOn Pass made a previously scary tethered boot easy. Installed Plex and it even plays my .avi files. Only hitches are as follows:

If you previously tried the bugged version of SeasOn Pass, you will need to trash the first IPSW and start over to rebuild a new file.

Needed to install aTV Black twice on both aTV's after tethered boot. First try didn't install.

Plex doesn't FF/Rew or show subtitles. This is most likely a Plex app issue not aTV Black.

Make sure you have the latest build of Plex or you will get error messages when you try to play files.

Thanks FireCore.

I would assume you found instructions online to install the plex?  Can you post that link here if possible?

Thanks for the feedback.

Glad to hear it's working well for you.  :)



I would assume you found instructions online to install the plex?  Can you post that link here if possible?



Just go to the 'Maintenance' menu after aTV Black is installed. Install Plex client. Install Plex on your Mac, make sure Plex Media Server is running and sees your video files. Build you library under 'Media Manager' in Plex server. Go to Plex servers on the aTV menu and click on your server name (most likely your computer). Plex application does not need to be running on your computer but Plex Media Server does. It's easy.

Awesome man!  THanks!

The whole thing worked pretty well with a just a couple of small bumps along the way:

• Initially I had trouble getting into DFU mode, because I was using a different Apple Remote than the one that came with it.  You need the real deal, because the Play button is not the same as the OK/Select button, even though they will act pretty much the same.  Also, sometimes it seemed like I had to connect the power cord to get it into DFU mode.  Occasionally, I ended up in Recovery instead of DFU.  For those who don't know, there's a nice tool out there to get yourself out of Recovery mode without going through a whole Restore. It's called "RecBoot" and I found it here:

• Seas0nPass 0.6.5 ran fine until it got to the part where it was selecting the .ipsw, then it would fail saying it couldn't locate it.  As others have mentioned, there seems to be a path error in the script.  I just did an Option-Restore in iTunes, which worked fine.

• After running the tethered reboot, the ATV hung, because it couldn't connect to WiFi.  Canceling out of thatopening screen and re-entering the WiFi credentials solved that issue.  I knew from a previous jailbreak that this was an issue, and that installing Nito would solve the WiFi problem, but inexperienced users may be thrown by that.

• After installing all the ATV software and doing a tethered boot, I came up with a black screen.  Since I wanted to change the password anyway, I SSH'd in, changed the password, and issued a killall AppleTV .  I then came up with the normal screen.

• Everything works pretty well so far.  I had run the very first jailbreak (untethered) for awhile with Plex.  This version seems to be having a problem playing video plug-ins like Hulu.  I can navigate the menus and see episodes,but nothing happens at all when I try to play them.  They work fine on the Plex server itself.  My own videos work fine though.

• CouchSurfer is pretty cool, but it would be nice to be able to more easily get back to the URL entry bar.  As it stands, it seems you have to exit back to the main menu each time you want to enter a new URL.  Perhaps I'm overlooking something.  

Of course, what I'm most interested in, is the ability to play other video codecs directly rather than via Plex.  I'm hoping we'll see that in the next beta?

Thanks for your efforts, and keep those betas coming!  8)

Dave, is it possible that you have the latest version of Adobe Flash installed?  The latest version of flash broke Plex's ability to show video through the plugins.  Here is a link to help, if that is the case:

Thanks for that suggestion, Josh.  Flash does seem to love to update itself, despite my best efforts to stop it. But, in this case that's not the issue. I'm running v10,0,45,2. When Flash breaks it, the video won't play on the Mac either.  In this case, it plays fine on the computer, but when I try to play it on the ATV nothing happens at all (no error, no sound, no lockup or delay.  It's as if I didn't try.)

Are you saying that Hulu is working fine for you with the latest iOS firmware and tethered jailbreak?


Sorry, Dave, unfortunately I have not had time to try the Seas0npass jb yet.  I plan on working on that tonight.  I just know when I was playing with Plex last time, I ran into the issue of no video (on the mac), and researched it to come up with the article I sent you. 

I will give it a shot tonight and update you with what I find out.  Keep me posted if you make any progress.




Thanks Josh, I had Plex running under the original untethered jailbreak (Prior to ATV Flash beta), and was able to play Hulu on the ATV, although it was pretty poor quality.  I was curious to see if any further progress had been made.  I can get Hulu+ with my Roku, but that doesn't include many shows that are available with a standard Desktop Hulu account. Everything plays fine on the Mac, but I don't seem to be able to even initiate the player on the ATV.  

EDIT:  Just saw that Plex was just updated.  The fix list includes VideoPlugs, so apparently this was a known issue.  I got tired of wading through that monstrous thread over there, and I guess I missed the post(s) where this got broken.

From Plex forum

Changes in this version:


  • Scrubbing, that is fast forward, rewind and seek implemented
  • Resume now works, even if you watched a part of the video on some other device/computer
  • Video plugins now work again
  • + more minor fixes

True to their word, this stuff all works great now.  And the quality of Hulu is now pretty watchable, which is fantastic!

How do you trash the first file ISPW?? In assume once I can locate that, and dump it, I can then download the new season pass and it will pull the firmware off the web and rebuild a proper ispw. Thanks so much for anyone that answers this as i have been pulling my hair out trying to figure this out!!

Dave, good news, I got my ATV2 jailbroken with Seas0nPass and then I got ATV flash installed perfectly!  It was pretty easy.

I did install the plex server on my macbook, and I installed the plex piece on the ATV.  I installed the plex Hulu plugin on the macbook, but it doesnt show up on the atv.  Any thoughts?  Am i doing something wrong?

All in all the jb was easy and pretty painless.  Nice work firecore!

Hi Josh,

Glad to hear you got it going.  In order for Hulu to show up and work, you need to go to Plex Media Server Preferences, go to the Advanced tab, and check "Disable capability checking".

Also, you need to update Plex to the latest version (0.6.4) in order for any of the video plugins or FF/FR to work.

Dave - thanks for the tip!  Everything showed up in my plugins after that.


ANy idea on how to update?  I tried through the built in updater on the mac, but it was no go.


EDIT:  NM, found this :)  Thanks again!

Updating the Plugin
Once in a while I might release an updated version for the plugin, so once in a while you might want to check for updates and install them. Here is how that will work:

  • Start your ATV and log in to your ATV using ssh
    ssh root@
  • In that ssh session enter
    apt-get update
    -get upgrade


Doing the update that way wasn’t quite enough for me, because the Plex project has been taken over by someone else, I had to first add a new Cydia source:

ssh root@Apple-TV.local
echo “deb ./downloads/PLEX/” > /etc/apt/sources.list.d/plex.list
apt-get update
apt-get upgrade

After that the ATV should respiring and the Plex version should be updated to 0.6.4 (or higher depending on how fast he updates again)
The forum keeps reformatting the first line improperly. It should be: ssh rootatApple-TV.local all on one line, with the @ symbol instead of at. Using Apple-TV.local is nice instead of the IP, since many folks won’t know the IP.

I don't have Cydia installed so how do I update Plex. Please someone point me in the right directioN!!!


LOL Nevermind that last Command Line worked!!!!! :)