Tether Boot issues...

Hello All,

So, I'm having an issue with Tetherbooting the atv2 via Seas0npass.

Some background:

OSX SnowLeopard via VMWare in Win 7, latest seas0npass. I've tried to boot in Win7 and OSX... 

I'm able to use Seas0nPass in the VM and generate the custom .ipsw. I'm also able to restore using the custom .ipsw in the OSX VM. I had issues with error 21, but doing a fresh restore then restoring with the custom worked. Once I unplug and replug back in, power too, and DFU the tetherboot piece starts, it uploads the iBSS fine, and moves onto the kernelcache, but this is where it hangs. The progress bar is seen for maybe 1-3% then dissappears and hangs.  

I also copied the custom firmware from the OSX VM to Win7, performed the restore with no issues (got one error 21, clean restore then custom fixed that), and downloaded tetheredboot utility. I pulled the iBSS and kernel cache from the ipsw (.zip), and tried to manually boot in Win7 via cmd..tetheredboot also starts, and gets to a point where it says "waiting for device to reconnect" and stops.

I end up just restoring to standard because I can't get it booted in Win or the OSX VM.

Anxious to get it working, any help or ideas would be great.  I'm assuming I'm having issues with the tool because of the OSX VM, but everything else runs smooth on the VM.  

Thanks in Advance,

DM

 

everything is working as expected.  browser, xbmc, plex (in osxvm), last.fm.  pretty sweet :)

one good thing to know is putting the atv2 to sleep, does not require you to re-tether boot. it stays booted while sleeping. +++

[quote="seeloesix"]

one good thing to know is putting the atv2 to sleep, does not require you to re-tether boot. it stays booted while sleeping. +++

[/quote]

 

I hope that's true. I've been afraid to put it asleep since I've got everything working.

The thing is - that some countries tend to completely power off the devices, and performing a tethered boot every time you plug it back in, is a no go.

When will there be a release - that I can switch off, and on without having to pass through the entire procedure again and again ?

 

Thx

It is :)  I've been running it jailbroken for about a week, and I've been sleeping it nightly :)

Although the atv2 wakes its self at random times, but I think this is it checking for a network ping....

Once there is an offical dev team release, or comex release, or greenpois0n release that "untethers" the jailbreak, Seas0npass will be updated to accommodate.  

On the same note my iphone 4 was replaced by apple yesterday (sad, lost jailbreak) and came with 4.2.1 stock. I'm waiting to jailbreak the iPhone until the untether is released for 4.2.1 (or 4.3), it does become a huge pain to tether boot....

rumor is there should be one soon, the above teams minus the dev team (focused on other tasks) are working on it.  greenpois0n demonstrated a 4.2.1 untether recently, but it is in testing before general release...

I finally got it to work :)

I uesd Seas0npass through the OSXVM to create the custom firmware. I then had to manually restore the atv2 in iTunes after putting it into DFU mode. 
I then copied the custom firmware to Win 7 and changed it to .zip file. I plucked the iBSS and kernelcache files out and used 'tetheredboot' utility to boot it up (in dfu mode): 
tetheredboot iBSS.k66ap.RELEASE.dfu kernelcache.release.k66 

u need all the files in the same folder. have iTunes recognize the atv2 before plugging power cord in and putting in DFU mode. 

was able to SSH in so far. :)
now on to XBMC and FireCore beta...