Take heart. It works

Like many I bought the beta only to discover I was running 4.2 and it wouldn’t work with the current jailbreaks.
Well greenpois0n took a number off attempts before it worked, but work it did.
The key was holding ‘menu and down arrow’, for the reboot and then straight away ‘menu and play’ until iTunes pops up. From there disconnect and run greenpois0n. It worked first time.

After, I had nitro tv on my menu. Well it actually hangs trying to find the network, press menu to get out of that screen and then re-enter network info.
From there I couldn’t instal xmbc. It just kept rebooting. I then tried ATV flash which worked, but no menu changes. After that I tried xmbc again, it worked and the additional menus appeared after reboot.

Oh you have to instal the cydia package early on, but it’s obvious. You can’t do anything but instal it.

Anyway, finally it’s working, currently I am using last fm through the tv and I am happy!

Thank goodness I saw this post. I finally got the jailbreak to work with GP 6. I could see NitoTv in the menu, but no Maintenance. Tried installing aTV Flash several times, no luck. Then I installed xmbc from NitoTV, it rebooted, and guess what? The Maintenace menu is now there.  Joy!

I tried JB with Seas0npass and that was not working for me..Yesterday I used GreenPois0n and all went well. JB my ATV2 and installed ATVFLASH. However when I try to install other items other than XMBC i get a message manual install "dpkq --configure -a"  I have no idea what this is???

Love ATVFlash and it's coming along very well......