System storage bug when deleting files. (solved)

As discussed by many in the community, infuse on iOS, in my particular case iPadOS, has a difficult relationship with the OS when it comes to deleting files and releasing storage. Even though per 7.5.2+ update, the deleted files should have been moved to ‘Recently Deleted’ folder in the Files app, it appears to be bugged again as of iPadOS 17.1.1 + infuse 7.6.4. No files were found under ‘Recently Deleted’ after the deletion of 159GB worth of files, and that storage space was not released.

Due to extreme reluctance to restore the OS, after several hours, a ‘.trash’ folder was located in File System>Apps>Infuse>Documents using iMazing management tool. This folder was only visible when ‘Show hidden files and folders’ was toggled in iMazing, although no file was found in the hidden folder, the system claimed that it was exactly 159GB large. System storage space was immediately released upon deleting this folder.

Hope this discovery helps whoever came to search.

3 Likes

Hmm interesting. Were these files deleted recently or were these deleted some time ago?

If I recall correctly, they were deleted on the 18th of November. So at the exact moment of deletion, the device was running iPadOS 17.1 rather than 17.1.1.

1 Like

Ok, and just to confirm you were running a recent version of Infuse at that point - at least something newer than 7.5.2?

I can’t be certain of Infuse’s version at that point. However with auto update on from the app store, there’s no reason Infuse could be any older than 1 version behind at any given time, if not the latest.

I just found this thread cause I just ran into this on my iPad Mini 6 on iPadOS 17.2, and Infuse 7.6.4656. I just deleted the files to make room for other ones and the space didn’t get released. I did it through the Files tab in Infuse, then tapping on the video and selecting delete from the 3-dot menu. The files didn’t go into the Recently Deleted in the Files app and now that storage can’t be recovered, I guess without that third party app for PC?

As of Infuse 7.6.6 + iPad OS 17.2, deleting the downloaded file within the Infuse app or the files app still results in unreleased storage space. However, if you do not perform the above actions, instead delete the files via “settings>general>iPad storage>Infuse>documents”, storage space will be released.

Sadly this does not solve storage occupied by previously deleted files, but it is a viable option to prevent further losses in the future.

I could delete the files after a while. They appeared in recently deleted. Not sure what triggered it but I don’t think infuse updated, nor the OS. May have been a reboot but I’m pretty sure I tried that before.

1 Like

I have been seeing the same issue: files I’ve been deleting from Infuse didn’t go to “Recently deleted” and space was never being freed. Instead I found them using iMazing in a folder called “.trash” under File System - Apps - Infuse - Documents.

These are all files I have deleted recently, on iPadOS 17.4.1 and with Infuse 7.7.5. So there definitely still is some bug there related to deleting files.