Synology running Plex server can't go to sleep when app running on apple tv4k (even appletv in standby).

Hello, wondering if anybody has the same issue, my Synology NAS running Plex app can not go to sleep when the infuse app is running on appletv 4k, even when I’m using other apps. The only way for the server to sleep I have to double tap the menu button the close Infuse completely then my NAS will go to sleep. This doesn’t happen when I’m on iPhone or iPad though.

I believe the AppleTV will keep connections open in the background. I think it’ll release them if the AppleTV goes to sleep.

My guess is that now Infuse can take advantage of background app refresh that’s what it’s doing. You can try going to the ATV settings General > Background App Refresh > and there select OFF for Infuse.

That’s going to really negate a big feature for Infuse since after doing that you will have to wait for it to complete the syncing when the app is open and active. Note, I believe that your iOS devices will do the same when they are plugged in and charging. I think background refresh is disabled when running off of battery only.

Thanks for the reply but I’d tried all that already, but still the same.

Who are you answering?

Does the same thing happen with the plex app?

I meant that I tried to turn off the background refresh but still the same.


Did you let the atv go to sleep and check with the background refresh turned off? That’s the real test. How long do you have the time before sleep on your nas?

Nas 15 mins, let the atv standby for 4-5 before.