Synology NAS shares not seen in available shares

I was trying out the new version 2 on my iPhone and whilst I can see the shared files on my Mac under “Available Shares”, my Synology NAS is not visible. The icon just keeps spinning and finds nothing.

I can add it manually by entering its IP address etc. and it works. Any ideas what is causing this and are there any settings I can change?


You’re not doing anything wrong, it’s just a quirk in the current version of Infuse 2.

However, we think we’ve found a way to solve this and plan to have improved share detection available in an upcoming version.


I wanted to out a word in for this fix/feature as well. I’m glad to see it’s being worked on, and hope to see the update soon.

I’ve had great luck with Infuse (ATV Flash version) on my ATV2 & my Synology DS212+, and purchased the new ios version when it was released based on that experience. I’ll admit I have been a little disappointed I haven’t been able to use it… Yet. Firecore has had a great track record of working through bugs like this, so I’m confident you all will tackle this one as well.

I’ll check the other posts of course, but if you have any timing updates you’d like to share…

Thank you,

I can see my NAS as an available share, but the NAS is on my wired network and I don’t seem to be able to connect to it using my home wi-if network (which is connected to my Ethernet switch)
I’ve tried my NAS account details and also guest access, neither of which will make a connection.
It’s a synology ds 414 NAS

Appreciate this is no real help but it might help in some way. I have a DS412+ and Infuse works perfectly with it. The NAS is wired into my router and then sent via wifi to my iPad and iPhone. Infuse saw my NAS and Windows PC and just required user names and passwords to connect.

I just downloaded an app called File Browser from Stratospherix. I went for the paid version but they also have a free version to allow testing connections. Those with problems with a NAS might want to try something like that to see if it can connect to their NAS. On my Ipad it scanned my network and found my DS412+ and my PC. On my iPhone it saw neither but all I had to do was type in the network name and it found it and connected. I’m suggesting that if people cannot connect with Infuse, they could try this and if it does not work either, it shows a problem with the setup rather than with Infuse.

Having said all that, it sounds as if the next version of Infuse has improved network support which can only be a good thing.