Synology NAS not recognizing custom metadata or posters?

I had previously been running a “proof of concept” set up with a nested folder of movies & tv shows being served up from my MacBook Pro via built-in Mac OS X file sharing. This worked like a charm when using Infuse from either my iPhone 7 Plus or my AppleTV 4 - all files served up in an organized and speedy fashion, custom metadata and/or posters (as relevant) displaying fine.

Last night I set up my new Synology DS216j+, got Infuse connected to it and able to browse & access all files, and then copied over the all of the movies & tv shows that had previously worked fine off of my MacBook Pro. Once copied, the movies & shows play fine via Infuse app on my phone & AppleTV, but neither the custom metadata or posters are being displayed in Infuse - for some reason, once I switched over to my Synology NAS, both of those stopped being recognized by the Infuse app.

I have verified that the metadata XML and custom posters are still in the same location, with the same filenames (matching the filename of the movie)… and I’ve tried manually clearing the metadata cache on my Infuse app, but they still aren’t being displayed.

Please help - additional Infuse settings? Something (more) I need to do on the Synology NAS to allow Infuse to read the non-m4v files that I have stored within my “videos” folder (xml & jpg)? Something else?

Thanks very much in advance.

Are you using UPnP or DLNA to connect to your Synology by chance? Due to the nature of how these streaming options work, they unfortunately do not make extra metadata/artwork files available to apps like Infuse.

In addition to UPnP/DLNA, Synology devices support SMB and NFS and using either of will allow Infuse to access you XML and image files as expected. This will also allow you to make use of Infuse’s Library feature, which isn’t available when using UPnP/DLNA.

SMB worked like a charm - thank you very much for the quick and helpful reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.